capistrano-tagging breaks with bundler >= 1.1rc #1

Merged
merged 1 commit into from Nov 28, 2011

2 participants

@arr-ee
$ bundle exec rails c
/home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/capistrano-tagging-  0.0.8/lib/capistrano/tagging.rb:7:in `load': wrong number of arguments (0 for 1) (ArgumentError)
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/capistrano-tagging-0.0.8/lib/capistrano/tagging.rb:7
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/bundler-1.1.rc/lib/bundler/runtime.rb:76:in `require'
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/bundler-1.1.rc/lib/bundler/runtime.rb:76:in `require'
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/bundler-1.1.rc/lib/bundler/runtime.rb:55:in `each'
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/bundler-1.1.rc/lib/bundler/runtime.rb:55:in `require'
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/bundler-1.1.rc/lib/bundler.rb:128:in `require'
from /home/mbarnash/work/domgeo/config/application.rb:5
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/railties-3.0.11/lib/rails/commands.rb:21:in `require'
from /home/mbarnash/.rvm/gems/ree-1.8.7-2011.03@domgeo/gems/railties-3.0.11/lib/rails/commands.rb:21
from script/rails:6:in `require'
from script/rails:6

I'm not sure what's the main cause of this, maybe it's somehow connected with changes in bundler's load mechanisms. Anyway, we'd better ensure we have Capistrano config to work with.

@dimko dimko merged commit 0c8b040 into dimko:master Nov 28, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment