disable history #1267

Open
Mexikaner9 opened this Issue Jan 7, 2017 · 10 comments

Projects

None yet

3 participants

@Mexikaner9

what is the simpliest way to disable history?

@chesio
chesio commented Jan 9, 2017

Have you tried options.history = false; ?

@Mexikaner9

this doesnt work

<script src='js/photoswipe.min.js'></script> <script src='js/photoswipe-ui-default.min.js'></script> <script src="js/index.js"></script> <script> var options = { history: false }; gallery.init(); </script> sorry, I'm not an Expert
@xor-gate
xor-gate commented Jan 9, 2017 edited

You need to set options on the instance of a gallery it is no config variable which "floats around":

var gallery = new PhotoSwipe( someElement, PhotoSwipeUI_Default, someItems, options);
gallery.init();

// Note that options object is cloned during the initialization.
// But you can access it via `gallery.options`.
// For example, to dynamically change `escKey`:
gallery.options.escKey = false;

// etcetera......
@Mexikaner9

ok, thank you!

@Mexikaner9

can you help me please?
my example doesnt work
http://dauten.server29.vorschauseite.eu/PhotoSwipe/

@Mexikaner9

please help me.
I'm just a beginner in js

@xor-gate
xor-gate commented Jan 14, 2017 edited

I'm sorry but screaming for help on github is just like drowing in the midatlantic ocean without boats passing by. People will always help over here, but you have to do your homework beforehand. Probably you should first learn some javascript before integrating existing applications. W3schools has some nice tutorials including javascript: http://www.w3schools.com/js/

@Mexikaner9

Learning Javascript has no priority for me. There are better things in life. I would like to use PhotoSwipe, but I can also use http://cornel.bopp-art.com/lightcase/

@chesio
chesio commented Jan 16, 2017

There are better things in life...

...than helping lazy strangers on GitHub. You nailed it!

If you would like to use PhotoSwipe, you should now that "PhotoSwipe is not a simple jQuery plugin, at least basic JavaScript knowledge is required to install." -- this is literally the second sentence on PhotoSwipe documentation page.

I wish you a good luck with some other plugin.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment