hstore support for activerecord-jdbcpostgresql-adapter #43

Closed
alhafoudh opened this Issue Sep 2, 2012 · 8 comments

Projects

None yet

6 participants

Is there any support for jruby?

Owner
diogob commented Sep 14, 2012

Sorry, I've never tested the gem with jruby, what's the issue when you try to run it?

soffes commented Sep 14, 2012

The root of the problem is the dependency on the pg gem which is incompatible with JRuby.

The sujithrs fork supports jruby, but it's falling behind.

https://github.com/sujithrs/activerecord-postgres-hstore

Owner
diogob commented Sep 28, 2012

I've installed the jruby env here and will give it a shot as soon as I can :)

Maybe you can fix it by adding to gemspec:

Gem::Specification.new do |s|
...
...
if RUBY_PLATFORM =~ /java/
s.add_dependency "activerecord-jdbcpostgresql-adapter"
else
s.add_dependency "pg"
end
...
...
end

Above will not fix it, since its the platform at building time of the gem.

Instead, I think the 'pg' should be a development dependency (add_development_dependency).

See https://github.com/dockyard/postgres_ext/blob/master/postgres_ext.gemspec for details.

@diogob diogob closed this Feb 4, 2013
@diogob diogob closed this Feb 4, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment