New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Table creation issue #1240

Closed
Kakoum opened this Issue Aug 19, 2016 · 5 comments

Comments

Projects
None yet
3 participants
@Kakoum

Kakoum commented Aug 19, 2016

I have almost the same mistake than : #1201
This issue is close and is not the same file, so i recreate a issue :s

Version Info

  • Directus version and branch: Last version on github, Master or Build
  • PHP version: 5.5
  • MySQL version: 5.6
  • Web server: (Ex. Apache, nginx or IIS?) Apache
  • OS name and version: Windows 10

Expected Behavior

Table should show up and be editable

Actual Behavior

Creating table (it shows up in phpmyadmin), not showing up below "tables"

Steps to Reproduce

  1. Create a table with some fields
  2. Try to look below tables

Logs or Screenshots

When i click on my "table" after creation :
Error: Uncaught TypeError: Cannot read property '_listenerId' of undefined File: http://localhost/directus/assets/js/directus.min.js?bust=vdmcsv1j5q7jvbfn6q384u0844 Line:8
And if i refresh my page, my table disappears

@benhaynes

This comment has been minimized.

Show comment
Hide comment
@benhaynes

benhaynes Aug 19, 2016

Contributor

Hey @Kakoum – are you creating the table in Directus or PHPMyAdmin? Do you have any column in it? If you can export the SQL for the table and include it here that might help. Thanks again for reporting this!

Contributor

benhaynes commented Aug 19, 2016

Hey @Kakoum – are you creating the table in Directus or PHPMyAdmin? Do you have any column in it? If you can export the SQL for the table and include it here that might help. Thanks again for reporting this!

@Kakoum

This comment has been minimized.

Show comment
Hide comment
@Kakoum

Kakoum Aug 20, 2016

Hello !
I create the table "Articles" in Directus directly. I add two fields (textinput and wyslwyg)
This is my screenshot of phpMyAdmin :
phpmyadmin
(4 columns).
After create table "Articles" and add news fields (in Directus), i want click on "Articles" (under "Tables") but i have this error javascript "Cannot read property '_listenerId' of undefined File".
After that i try to refresh my page, and "Articles" disappears.

Kakoum commented Aug 20, 2016

Hello !
I create the table "Articles" in Directus directly. I add two fields (textinput and wyslwyg)
This is my screenshot of phpMyAdmin :
phpmyadmin
(4 columns).
After create table "Articles" and add news fields (in Directus), i want click on "Articles" (under "Tables") but i have this error javascript "Cannot read property '_listenerId' of undefined File".
After that i try to refresh my page, and "Articles" disappears.

@Kakoum

This comment has been minimized.

Show comment
Hide comment
@Kakoum

Kakoum Aug 20, 2016

Ok i can create table, is nice.
I can reproduce the bug with these steps :

  • Create new table
  • Add field textinput + save item
  • Add field wysiwyg + save item
  • Save item (save table)

I think is because i create two fields following.
I cant recreate my table "Articles", Directus say "This table already exist!", but i cant see her on Directus (only on my database)

Kakoum commented Aug 20, 2016

Ok i can create table, is nice.
I can reproduce the bug with these steps :

  • Create new table
  • Add field textinput + save item
  • Add field wysiwyg + save item
  • Save item (save table)

I think is because i create two fields following.
I cant recreate my table "Articles", Directus say "This table already exist!", but i cant see her on Directus (only on my database)

@benhaynes

This comment has been minimized.

Show comment
Hide comment
@benhaynes

benhaynes Aug 21, 2016

Contributor

Hey @Kakoum – we're having trouble replicating this issue so we're going to move it to the 6.3.1 patch. We'll fix it as soon as we can find find reliable steps to reproduce. Thanks again for reporting! Let us know if you're still experiencing it after upcoming the 6.3 merge and deploy.

Contributor

benhaynes commented Aug 21, 2016

Hey @Kakoum – we're having trouble replicating this issue so we're going to move it to the 6.3.1 patch. We'll fix it as soon as we can find find reliable steps to reproduce. Thanks again for reporting! Let us know if you're still experiencing it after upcoming the 6.3 merge and deploy.

@WellingGuzman

This comment has been minimized.

Show comment
Hide comment
@WellingGuzman

WellingGuzman Aug 30, 2016

Member

@Kakoum We've found the bug and fixed it.

Tables were being saved as nav_listed = 0 that prevented the table from being listed in the navigation (sidebar).

Member

WellingGuzman commented Aug 30, 2016

@Kakoum We've found the bug and fixed it.

Tables were being saved as nav_listed = 0 that prevented the table from being listed in the navigation (sidebar).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment