Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
The Railslove Deploy recipes to setup a Rail/rack app from scratch
Ruby Shell
tag: v0.4.6

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
bin
lib
test
.gitignore
LICENSE
Rakefile
TODO
VERSION.yml
readme.mdown

readme.mdown

Railslove Deploy

The Railslove deploy gem to setup a full ruby server stack. Includes Sprinkle setup scripts and Capistrano deployment recipes.

Contact

There is no nice documentation or readme file yet but if you have any problems questions feel free to contact me anytime:

michael@railslove.com skype:derbumi.de irc: derbumi on freenode titter: @bumi

Idea

The Railslove_deploy gem provides some sprinkle and capistrano recipes to setup a full server stack and deploy your application. It tries to be as configurable as possible by providing a configurable collection of recipies simple recipes.

How to get you going

1. deployify

Run the deployify command in your application root directory to generate all the deployment files

bumi:~/development/rails_apps/stuff/deploy_demo 
→ deployify .
[Deployment files created]

This generates the default capistrano files (Capfile and config/deploy.rb) and a config/server directory containing the server configuration files:

2. Adjust your config/deploy.rb file

Adjust the deploy file for your needs. Enter the IPs of your Server, configure your callbacks, etc.

3. Adjust your config/server/policy.rb file

The policy file describes how your server should look like. Here you can configure the packages you want to install.

The default policy installs the following:

policy :passenger_stack, :roles => :app do
  requires :webserver         # Apache
  requires :database          # MySQL or SQLite

  # memcached
  requires :memcached_daemon  # Memcached
  requires :libmemcached      # libmemcached
  requires :memcached_conf    # memcached-user, init.d config 

  requires :scm               # Git or SVN
  requires :ruby              # Ruby Enterprise
  requires :searchengine      # Sphinx
  requires :appserver         # passenger
  requires :rails_user        # special rails user with sudo rights
  requires :database_driver   # Ruby database driver
  requires :usefull_gems      # usefull, frequently needed gems
  requires :image_magick      # image magick
  requires :ferm              # ferm iptable configuration tool
  requires :ferm_conf         # configure ferm (allow http, https and ssh)
  requires :monit             # monit - system process monitoring
  requires :munin_node        # install munin-node for system monitoring
  requires :munin_apache_status # configure extended apache status information
end

4. use the sprinkle command to run your policy and setup your server

sprinkle - s config/server/policy.rb

Now sprinkle parses your policy and load the recipes and installs it on the server. After that you're server is ready to deploy.

5. cap deploy:setup

6. cap deploy:cold

You're done. :D

Notes

not included packages

curl/libcurl

to install libcurl try: apt-get install libcurl4-openssl-dev If apt-get fails to install libcurl4-openssl-dev, try libcurl-dev, libcurl4-gnutls-dev, or libcurl3-gnutls-dev.

Issues

  • Sprinkle does not have any rollback function if something fails.
Something went wrong with that request. Please try again.