Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dispatch error when logging in: thread 'main' panicked at 'called `Option::unwrap()` on a `None` value'. #18

Closed
cfanoulis opened this issue Mar 10, 2020 · 6 comments
Assignees
Labels
bug

Comments

@cfanoulis
Copy link

@cfanoulis cfanoulis commented Mar 10, 2020

Describe the bug
When trying to login, dispatch burps the following error:

thread 'main' panicked at 'called `Option::unwrap()` on a `None` value', src/libcore/option.rs:347:21
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace

Steps to reproduce

  1. Run dispatch login
  2. See error

Expected behavior
The login flow begins

Actual behaviour
Dispatch panics and throws the above error

Additional context
Full trace: https://hasteb.in/wapizeyu.rb
I was suggested to downgrade openssl, but that didn't help

@msciotti

This comment has been minimized.

Copy link
Contributor

@msciotti msciotti commented Mar 10, 2020

This is a known issue with linux and Dispatch. Some more info:

I looked at the backtrace that occurs on linux, and it seems like Discord uses reqwest per said libraries README OpenSSL 1.0.1, 1.0.2, or 1.1.0 is supported. So you can attempt to roll back in-order to make it work. Rolling back your openssl comes with consequences though, such as possibly completely messing up your installation.

Downgrading OpenSSL to 1.1.0 or lower should work, what did you downgrade to?

In the meantime, raising this issue internally again.

@cfanoulis

This comment has been minimized.

Copy link
Author

@cfanoulis cfanoulis commented Mar 10, 2020

I downgraded to openssl 1.1.0 from the official apt repos and ssl 1.0.2 from ubuntu-security... not only did they not work, 1.0.2 also made my linux installation unbootable

@sylveon

This comment has been minimized.

Copy link

@sylveon sylveon commented Mar 10, 2020

Downgrading major OpenSSL versions is always a terrible idea because a lot of critical system components are linked to it, and pin to a major version (a program linked against 1.0 can't use 1.1 and vice-versa). This is not a good suggestion, and it will most likely lead to more broken Linux installs than fixed dispatch installs.

If you are on Arch Linux, you can install the openssl-1.0 package to keep both major versions installed side by side: https://www.archlinux.org/packages/core/x86_64/openssl-1.0/

@cfanoulis

This comment has been minimized.

Copy link
Author

@cfanoulis cfanoulis commented Mar 25, 2020

heyo, any update on this?

@samschlegel samschlegel closed this Apr 7, 2020
@msciotti

This comment has been minimized.

Copy link
Contributor

@msciotti msciotti commented Apr 7, 2020

We've got a working version that we'll be releasing shortly!

@cfanoulis

This comment has been minimized.

Copy link
Author

@cfanoulis cfanoulis commented Apr 7, 2020

hooray! Thanks a lot!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.