New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

reltable: non-working related links generated to topics not in output #1431

Closed
leighw opened this Issue Jan 3, 2013 · 1 comment

Comments

Projects
None yet
2 participants
@leighw

leighw commented Jan 3, 2013

Applies to (at least) OT 1.5.4, 1.6.1, 1.7, PDF output with FOP, XEP. Not tested with Antenna House.

Scenario: I have a reltable that specifies that TopicA should have a related link to TopicB and TopicC. I use this reltable with a map that does not reference TopicC. In the resulting PDF output, TopicA contains a working related link to TopicB and a non-working related link to TopicC. Neither the map nor the reltable use @collection-type. The build specifies not to include family links.

This is not the expected behavior. Descriptions of reltable functionality specify that reltables do not generate related links to topics that are not referenced by the input map. This is the behavior observed in XHTML and HTML Help builds.

@jelovirt

This comment has been minimized.

Show comment
Hide comment
@jelovirt

jelovirt Jan 4, 2013

Member

Can't see where the DITA 1.2 spec says dead links are not generated from reltables, so marking this as a feature, not a bug.

Member

jelovirt commented Jan 4, 2013

Can't see where the DITA 1.2 spec says dead links are not generated from reltables, so marking this as a feature, not a bug.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment