Permalink
Browse files

referenced 2.4 upgrade

  • Loading branch information...
1 parent 10ad5fb commit b7c17c2e8198e613995380b8eab35ed6cd86f0d9 @digi604 digi604 committed Sep 21, 2012
Showing with 11 additions and 4 deletions.
  1. +1 −0 docs/index.rst
  2. +10 −4 docs/upgrade/2.4.rst
View
1 docs/index.rst
@@ -17,6 +17,7 @@ Install
:maxdepth: 1
getting_started/installation
+ upgrade/2.4
upgrade/2.3.3
upgrade/2.3.2
upgrade/2.3
View
14 docs/upgrade/2.4.rst
@@ -6,9 +6,13 @@
What's new in 2.4
*****************
-..
- New feature
- ===========
+Removed the MultilingualMiddleware
+==================================
+
+We removed the MultilingualMiddleware. This removed the very ugly monkey patching of the
+reverse() function as well. As a benefit we now support localization of urls and Apphook urls.
+
+
..
Feature description
@@ -26,7 +30,9 @@ Backwards incompatible changes
New minimum requirements for dependencies
=========================================
-.. * ``package`` must now be at version X.Y
+If you are running django 1.3.X you need to install django-i18nurls, if you want
+multilingual features. The cms.urls needs to be in a i18n url pattern.
+
********************

0 comments on commit b7c17c2

Please sign in to comment.