Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #4304 from divio/fix/django1.6warnings

Adds security warnings about using Django 1.6
  • Loading branch information...
commit 1fd27f375ef4109e85e5983d10b96199e882cfab 2 parents ddd6c13 + 2bbd71c
@evildmp evildmp authored
Showing with 16 additions and 0 deletions.
  1. +8 −0 docs/introduction/install.rst
  2. +8 −0 docs/upgrade/3.1.rst
View
8 docs/introduction/install.rst
@@ -75,6 +75,14 @@ For the purposes of this tutorial, it's recommended that you answer the
installer's questions as follows - where our suggestions differ from the
default, they're highlighted below:
+.. warning:: Django security support
+
+ Django 1.6 support is provided as an interim measure only. In accordance with the `Django
+ Project's security policies <https://docs.djangoproject.com/en/dev/internals/security/>`_, 1.6
+ no longer receives security updates from the Django Project team. Projects running on Django
+ 1.6 have known vulnerabilities, so don't choose to install this version unless you have a
+ particular need to.
+
* Database configuration (in URL format): sqlite://localhost/project.db
* django CMS version: stable
* Django version: stable
View
8 docs/upgrade/3.1.rst
@@ -67,6 +67,14 @@ Dropped support for Django 1.4 and 1.5
Starting from version 3.1, django CMS runs on Django 1.6 (specifically, 1.6.9 and later) and 1.7.
+.. warning:: Django security support
+
+ Django 1.6 support is provided as an interim measure only. In accordance with the `Django
+ Project's security policies <https://docs.djangoproject.com/en/dev/internals/security/>`_, 1.6
+ no longer receives security updates from the Django Project team. Projects running on Django
+ 1.6 have known vulnerabilities, so you are advised to upgrade your installation to 1.7 or 1.8
+ as soon as possible.
+
Action required
---------------
Please sign in to comment.
Something went wrong with that request. Please try again.