Permalink
Browse files

Dropped support for Django 1.3 and Python 2.5

This commit only updates the documentation and modifies the Travis and
setup.py requirements.
  • Loading branch information...
1 parent 3b0eee6 commit dfd4015c838417dc286b382eedbbad2375d325d4 @bikeshedder bikeshedder committed Mar 27, 2013
Showing with 20 additions and 19 deletions.
  1. +0 −4 .travis.yml
  2. +2 −0 CHANGELOG.txt
  3. +7 −7 docs/getting_started/installation.rst
  4. +10 −2 docs/upgrade/2.4.rst
  5. +1 −1 setup.py
  6. +0 −5 test_requirements/django-1.3.txt
View
@@ -1,12 +1,8 @@
language: python
python:
- - "2.5"
- "2.6"
- "2.7"
env:
- - DJANGO=test_requirements/django-1.3.txt DB='sqlite://localhost/:memory:'
- - DJANGO=test_requirements/django-1.3.txt DB='mysql://root@127.0.0.1/djangocms_test'
- - DJANGO=test_requirements/django-1.3.txt DB='postgres://postgres@127.0.0.1/djangocms_test'
- DJANGO=test_requirements/django-1.4.txt DB='sqlite://localhost/:memory:'
- DJANGO=test_requirements/django-1.4.txt DB='mysql://root@127.0.0.1/djangocms_test'
- DJANGO=test_requirements/django-1.4.txt DB='postgres://postgres@127.0.0.1/djangocms_test'
View
@@ -122,6 +122,8 @@
Please see Install/2.4 release notes *before* attempting to upgrade to version 2.4.
+- Compatibility with Django 1.4 and 1.5 (1.3 support dropped)
+- Support for Python 2.5 dropped
- CMS_LANGUAGE setting has changed
- CMS_HIDE_UNTRANSLATED setting removed
- CMS_LANGUAGE_FALLBACK setting removed
@@ -10,7 +10,7 @@ Requirements
************
* `Python`_ 2.5 (or a higher release of 2.x).
-* `Django`_ 1.3.7, 1.4.5, 1.5 or higher
+* `Django`_ 1.4.5, 1.5 or higher
* `South`_ 0.7.2 or higher
* `PIL`_ 1.1.6 or higher
* `django-classy-tags`_ 0.3.4.1 or higher
@@ -40,11 +40,11 @@ Recommended
* `django-filer`_ with its `django CMS plugins`_, file and image management
application to use instead of some core plugins
-* `django-reversion`_ 1.5.7 (with Django 1.3.7), 1.6.6 (with Django 1.4.5),
- 1.7 (with Django 1.5) to support versions of your content (If using a
- different Django version it is a good idea to check the page
- `Compatible-Django-Versions`_ in the django-reversion wiki in order to
- make sure that the package versions are compatible.)
+* `django-reversion`_ 1.6.6 (with Django 1.4.5), 1.7 (with Django 1.5)
+ to support versions of your content (If using a different Django version
+ it is a good idea to check the page `Compatible-Django-Versions`_ in the
+ django-reversion wiki in order to make sure that the package versions are
+ compatible.)
.. _django-filer: https://github.com/stefanfoulis/django-filer
.. _django CMS plugins: https://github.com/stefanfoulis/cmsplugin-filer
@@ -68,7 +68,7 @@ started:
sudo aptitude install python2.6 python-setuptools python-imaging
sudo easy_install pip
- sudo pip install Django==1.4 django-cms south
+ sudo pip install Django==1.5 django-cms south
Additionally, you need the Python driver for your selected database:
View
@@ -18,6 +18,15 @@ What's new in 2.4
:ref:`cms-moderator-upgrade` below.
+Introducing Django 1.5 support, dropped support for Django 1.3 and Python 2.5
+=============================================================================
+
+Django CMS 2.4 introduces Django 1.5 support.
+
+In django CMS 2.4 we dropped support for Django 1.3 and Python 2.5.
+Django 1.4 and Python 2.6 are now the minimum required versions.
+
+
.. _migrations-upgrade:
Migrations overhaul
@@ -325,8 +334,7 @@ Backwards incompatible changes
New minimum requirements for dependencies
=========================================
-If you are running django 1.3.X you need to install django-i18nurls, if you want
-multilingual features. The ``cms.urls`` needs to be in a i18n url pattern.
+* Django 1.3 and Python 2.5 are no longer supported.
********************
View
@@ -28,7 +28,7 @@
platforms=['OS Independent'],
classifiers=CLASSIFIERS,
install_requires=[
- 'Django>=1.3.1,<1.6',
+ 'Django>=1.4,<1.6',
'django-classy-tags>=0.3.4.1',
'south>=0.7.2',
'html5lib',
@@ -1,5 +0,0 @@
--r requirements_base.txt
--e git://github.com/digi604/django-i18nurls.git#egg=django-i18nurls
-Django>=1.3.7,<1.4
-django-reversion>=1.5.7,<1.6
-psycopg2==2.3

0 comments on commit dfd4015

Please sign in to comment.