Cross Domain Request Error #1

Closed
digi604 opened this Issue Apr 17, 2009 · 4 comments

Comments

Projects
None yet
4 participants
@digi604
Contributor

digi604 commented Apr 17, 2009

If you store the media on a different domain the rich text editor causes a JavaScript editor when it attempts to load the HTML file.

You can repeat this by doing the following. If the following config for the site/media; site_root – www.mydomain.com media_url – media.mydomain.com admin_media = admin.mydomain.com

Then when you go to the admin and add a text plugin, trying to edit will cause a JavaScript error a request is being made from www.mydomain.com to media.mydomain.com . This is a problem since cross domain requests are not allowed for security reasons. Change History (follow-up: ↓ 2 ) 03/30/09 13:28:32 changed by divio ¶

how does the normal admin handles this issue with the javascript files it loads? (in reply to: ↑ 1 ) 04/04/09 19:45:01 changed by guest ¶

Replying to divio:

how does the normal admin handles this issue with the javascript files it loads?

contrib.admin doesn’t user any Ajax so cross domain issues are not well an issue. 04/06/09 16:17:18 changed by divio ¶

how do you handle this if you use ajax anywhere on your site?

@d0ugal

This comment has been minimized.

Show comment Hide comment
@d0ugal

d0ugal Apr 17, 2009

This might well be useful for this bug; https://developer.mozilla.org/En/Same_origin_policy_for_JavaScript

d0ugal commented Apr 17, 2009

This might well be useful for this bug; https://developer.mozilla.org/En/Same_origin_policy_for_JavaScript

@digi604

This comment has been minimized.

Show comment Hide comment
@yml

This comment has been minimized.

Show comment Hide comment
@yml

yml Feb 2, 2010

Contributor

The same problem happens with wymeditor, it causes me a major headache. This might not be issue of django-cms but it is worth to note in bold in the deployment section.

Contributor

yml commented Feb 2, 2010

The same problem happens with wymeditor, it causes me a major headache. This might not be issue of django-cms but it is worth to note in bold in the deployment section.

@ojii

This comment has been minimized.

Show comment Hide comment
@ojii

ojii Aug 29, 2010

Collaborator

this is an upstream issue and thus I'll close this ticket

Collaborator

ojii commented Aug 29, 2010

this is an upstream issue and thus I'll close this ticket

skrat added a commit to skrat/django-cms that referenced this issue Aug 20, 2011

alesdotio pushed a commit to alesdotio/django-cms that referenced this issue Nov 6, 2012

evildmp added a commit that referenced this issue Jan 17, 2013

Merge pull request #1 from ojii/evildmp-check-plugins
split cms.tests.check into two classes

kux referenced this issue in kux/django-cms Feb 15, 2013

Merge pull request #1 from pbs/issue_1634
Fix for django-cms issue 1634

ianare pushed a commit to ianare/django-cms that referenced this issue Oct 3, 2013

Merge pull request #1 from meshy/feature/django_16
Fix query counting tests for django 1.6.

digi604 pushed a commit that referenced this issue Feb 27, 2014

Merge pull request #1 from divio/develop
updating fork from master

FinalAngel added a commit that referenced this issue Oct 2, 2015

czpython added a commit that referenced this issue Dec 3, 2015

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment