mptt version conflicts combining django-cms with django-wiki #1614

Closed
iamit opened this Issue Jan 24, 2013 · 6 comments

Comments

Projects
None yet
4 participants
@iamit

iamit commented Jan 24, 2013

see http://stackoverflow.com/questions/14502799/django-cms-and-django-wiki-conflicts-in-required-django-mttp-version
I try to install both django-cms and django-wiki the latest pypi versions (using buildout)

combining django-wiki with the requirement for django-cms, I get:
django-cms 2.3.5 requires 'django-mptt>=0.5.1,<0.5.3'

django-wiki seem to have a good reason why using 0.5.3 ... (bugfix) so is it possible to upgrade django-cms to a version higher?

@benjaoming

This comment has been minimized.

Show comment Hide comment
@benjaoming

benjaoming Feb 3, 2013

Contributor

django-mptt 0.5.4 seems to work with django-cms 2.3.x

django-mptt/django-mptt#207

I would suggest to change the requirements file to django-cms to permit 0.5.4 as it is compatible with django-wiki as well.

I've tested with django-mptt 0.5.5

The immediate fix is to just install django-cms and then afterwards do pip install django-mptt --upgrade

Cross post in https://github.com/benjaoming/django-wiki/issues/98

Contributor

benjaoming commented Feb 3, 2013

django-mptt 0.5.4 seems to work with django-cms 2.3.x

django-mptt/django-mptt#207

I would suggest to change the requirements file to django-cms to permit 0.5.4 as it is compatible with django-wiki as well.

I've tested with django-mptt 0.5.5

The immediate fix is to just install django-cms and then afterwards do pip install django-mptt --upgrade

Cross post in https://github.com/benjaoming/django-wiki/issues/98

@iamit

This comment has been minimized.

Show comment Hide comment
@iamit

iamit Feb 3, 2013

@benjaoming: Great, thanks for this workaround and even looking further in to it! However I install everything (or at east as much as possible) on the djangoserver using buildout. This way I can use different versions of any install on 1 fysical server. So I have to look in if that's possible in buildout....

But the real solution would be if the requierement in django-cms will be adjusted.....

iamit commented Feb 3, 2013

@benjaoming: Great, thanks for this workaround and even looking further in to it! However I install everything (or at east as much as possible) on the djangoserver using buildout. This way I can use different versions of any install on 1 fysical server. So I have to look in if that's possible in buildout....

But the real solution would be if the requierement in django-cms will be adjusted.....

@digi604

This comment has been minimized.

Show comment Hide comment
@digi604

digi604 Feb 10, 2014

Contributor

mptt removal should fix this

Contributor

digi604 commented Feb 10, 2014

mptt removal should fix this

@digi604 digi604 added this to the 3.X milestone Feb 10, 2014

@benjaoming

This comment has been minimized.

Show comment Hide comment
@benjaoming

benjaoming Feb 10, 2014

Contributor

@digi604 so the fix now is to use django-cms 3?

Contributor

benjaoming commented Feb 10, 2014

@digi604 so the fix now is to use django-cms 3?

@iamit

This comment has been minimized.

Show comment Hide comment
@iamit

iamit Feb 11, 2014

sorry, haven't been working on this project for a while... more urgent matters :)
In case django-cms 3 and a version of django-wiki have overlap in their requirements, that should be the fix... not in the oppertunity to test this soon...

iamit commented Feb 11, 2014

sorry, haven't been working on this project for a while... more urgent matters :)
In case django-cms 3 and a version of django-wiki have overlap in their requirements, that should be the fix... not in the oppertunity to test this soon...

@yakky

This comment has been minimized.

Show comment Hide comment
@yakky

yakky May 28, 2014

Contributor

This is solved on django CMS as django-mptt 0.6 satisfies both django-wiki and django CMS requirements

Contributor

yakky commented May 28, 2014

This is solved on django CMS as django-mptt 0.6 satisfies both django-wiki and django CMS requirements

@yakky yakky closed this May 28, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment