Permalink
Browse files

Fix old dependencies to ruby-php-serialization name

  • Loading branch information...
1 parent 17d81fd commit 4644c903a75d1e083d084466970697ad7e69d4ff @divoxx committed Oct 2, 2009
Showing with 9 additions and 10 deletions.
  1. +3 −3 Rakefile
  2. +1 −1 features/support/env.rb
  3. +1 −1 lib/php_serialization/parser.rb
  4. +1 −1 lib/php_serialization/parser.y
  5. +2 −3 php-serialization.gemspec
  6. +1 −1 spec/spec_helper.rb
View
@@ -57,15 +57,15 @@ Rake::RDocTask.new do |rdoc|
end
rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "ruby-php-serialization #{version}"
+ rdoc.title = "Ruby's PhpSerialization #{version}"
rdoc.rdoc_files.include('README*')
rdoc.rdoc_files.include('lib/**/*.rb')
end
-file 'lib/ruby_php_serialization/parser.rb' => 'lib/ruby_php_serialization/parser.y' do |t|
+file 'lib/php_serialization/parser.rb' => 'lib/php_serialization/parser.y' do |t|
`racc -o #{t.name} #{t.prerequisites[0]}`
end
desc "Compile all the necessary files, such as .y grammar files"
-task :compile => ['lib/ruby_php_serialization/parser.rb']
+task :compile => ['lib/php_serialization/parser.rb']
View
@@ -1,4 +1,4 @@
$LOAD_PATH.unshift(File.dirname(__FILE__) + '/../../lib')
-require 'ruby_php_serialization'
+require 'php_serialization'
require 'spec/expectations'

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
@@ -63,7 +63,7 @@ rule
end
---- header ----
-require 'ruby_php_serialization/tokenizer'
+require 'php_serialization/tokenizer'
---- inner ----
@@ -23,15 +23,14 @@ Gem::Specification.new do |s|
"README.rdoc",
"Rakefile",
"VERSION",
- "features/ruby_php_serialization.feature",
- "features/step_definitions/ruby_php_serialization_steps.rb",
+ "features/php_serialization.feature",
+ "features/step_definitions/php_serialization_steps.rb",
"features/support/env.rb",
"lib/php_serialization.rb",
"lib/php_serialization/parser.rb",
"lib/php_serialization/parser.y",
"lib/php_serialization/tokenizer.rb",
"php-serialization.gemspec",
- "ruby-php-serialization.gemspec",
"spec/php_serialization_spec.rb",
"spec/spec_helper.rb"
]
View
@@ -1,6 +1,6 @@
$LOAD_PATH.unshift(File.dirname(__FILE__))
$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
-require 'ruby_php_serialization'
+require 'php_serialization'
require 'spec'
require 'spec/autorun'

0 comments on commit 4644c90

Please sign in to comment.