Permalink
Browse files

Add a note on elasticsearch-py versioning with regards to 1.0

  • Loading branch information...
1 parent fae22c5 commit 194f8aea2a1ae2e3f70eda7f870a65e4aa3b2627 @HonzaKral HonzaKral committed Feb 11, 2014
Showing with 7 additions and 0 deletions.
  1. +7 −0 docs/installing_search_engines.rst
@@ -159,6 +159,13 @@ You'll also need an Elasticsearch binding: elasticsearch-py_ (**NOT**
.. _elasticsearch-py: http://pypi.python.org/pypi/elasticsearch/
.. note::
+
+ Elasticsearch 1.0 is slightly backwards incompatible so you need to make sure
+ you have the proper version of `elasticsearch-py` installed - releases with
+ major version 1 (1.X.Y) are to be used with Elasticsearch 1.0 and later, 0.4
+ releases are meant to work with Elasticsearch 0.90.X.
+
+.. note::
``elasticsearch`` has its own dependencies that aren't covered by
Haystack. You'll also need ``urllib3``.

0 comments on commit 194f8ae

Please sign in to comment.