Permalink
Browse files

Tests: remove legacy targets

* Django 1.4 is no longer supported as per the documentation
* Travis: use Python 3.3 targets instead of 3.2
  • Loading branch information...
1 parent 372b37f commit 6f01d7f872d060828e6ee64c1e4ad39f1d28a82a @acdha acdha committed Jan 30, 2014
Showing with 2 additions and 21 deletions.
  1. +2 −4 .travis.yml
  2. +0 −17 tox.ini
View
@@ -15,14 +15,12 @@ script:
- tox -e $TOX_ENV
env:
- - TOX_ENV=py26-django1.4
- TOX_ENV=py26-django1.5
- TOX_ENV=py26-django1.6
- - TOX_ENV=py27-django1.4
- TOX_ENV=py27-django1.5
- TOX_ENV=py27-django1.6
- - TOX_ENV=py32-django1.5
- - TOX_ENV=py32-django1.6
+ - TOX_ENV=py33-django1.5
+ - TOX_ENV=py33-django1.6
services:
- elasticsearch
View
@@ -1,9 +1,7 @@
[tox]
envlist = docs,
- py26-django1.4,
py26-django1.5,
py26-django1.6,
- py27-django1.4,
py27-django1.5,
py27-django1.6,
py33-django1.5,
@@ -30,30 +28,19 @@ deps = Django==1.6
deps = Django==1.5.5
{[base]deps}
-[django1.4]
-deps = Django==1.4.10
- {[base]deps}
-
[testenv]
setenv =
PYTHONPATH = {toxinidir}/tests
TEST_RUNNER_ARGS = -v0
commands =
{toxinidir}/tests/run_all_tests.sh
-[testenv:pypy-django1.4]
-deps = {[django1.4]deps}
-
[testenv:pypy-django1.5]
deps = {[django1.5]deps}
[testenv:pypy-django1.6]
deps = {[django1.6]deps}
-[testenv:py26-django1.4]
-basepython = python2.6
-deps = {[django1.4]deps}
-
[testenv:py26-django1.5]
basepython = python2.6
deps = {[django1.5]deps}
@@ -62,10 +49,6 @@ deps = {[django1.5]deps}
basepython = python2.6
deps = {[django1.6]deps}
-[testenv:py27-django1.4]
-basepython = python2.7
-deps = {[django1.4]deps}
-
[testenv:py27-django1.5]
basepython = python2.7
deps = {[django1.5]deps}

0 comments on commit 6f01d7f

Please sign in to comment.