Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Whoosh 2.5 support #819

Closed
slav0nic opened this Issue Jul 4, 2013 · 6 comments

Comments

Projects
None yet
6 participants

slav0nic commented Jul 4, 2013

haystack 2.0 does't work with whoosh 2.5

ImportError: cannot import name SpellChecker

whoosh.spelling.SpellChecker class deprecated and was removed from Whoosh https://bitbucket.org/mchaput/whoosh/diff/src/whoosh/spelling.py?diff2=acbd1312c3f2&at=default

@rafacouto rafacouto referenced this issue in agoravoting/agora-ciudadana Jul 14, 2013

Open

SpellChecker was removed from Whoosh #32

rwblue commented Jul 17, 2013

try to use whoosh 2.4

on Mac OS I can't install 2.4...
sudo pip install whoosh==2.4 installs whoosh-2.5.1, and I can't fint the 2.4 anywhere on the internet.
when will haystack support the last version of whoosh?

Contributor

acdha commented Jul 24, 2013

@caesarsol Try pip install whoosh==2.4.1 or, better, pip install 'whoosh<2.5'

Contributor

acdha commented Jul 24, 2013

Try uninstalling whoosh first — the syntax above works normally unless some
other installed package requires 2.5

@caesarsol pip install -U whoosh==2.4.1

Contributor

toastdriven commented Jul 28, 2013

This is fixed as of Haystack v2.1.0, which adds support for Whoosh 2.5.0+.

@xiongchiamiov xiongchiamiov referenced this issue in xiongchiamiov/jellylorum Jul 29, 2013

Open

Upgrade whoosh and haystack #1

@stefanw stefanw added a commit to stefanw/celery-haystack that referenced this issue Mar 25, 2014

@stefanw stefanw Stick whoosh<2.5 for Haystack v1 requirements
Latest whoosh does not work with old haystack.
See django-haystack/django-haystack#819
755c0b0

@stefanw stefanw added a commit to stefanw/celery-haystack that referenced this issue Mar 25, 2014

@stefanw stefanw Stick whoosh<2.5 for Haystack v1 requirements
Latest whoosh does not work with old haystack.
See django-haystack/django-haystack#819
38c503d

@stefanw stefanw added a commit to stefanw/celery-haystack that referenced this issue May 27, 2014

@stefanw stefanw Stick whoosh<2.5 for Haystack v1 requirements
Latest whoosh does not work with old haystack.
See django-haystack/django-haystack#819
36a5a20
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment