Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

django-oscar-views version conflict #7

Closed
a-musing-moose opened this Issue Dec 2, 2012 · 4 comments

Comments

Projects
None yet
4 participants

Oscar 0.4 required django-extra-views>=0.2.4 (but <0.3)
This extension requires version 0.5.2

This conflict causes some pain on install and may prevent automated installation

Contributor

codeinthehole commented Dec 6, 2012

Why is v0.5.2 required? Is the right solution to change Oscar's dependencies?

@codeinthehole codeinthehole added a commit that referenced this issue Dec 6, 2012

@codeinthehole codeinthehole Add install target
Doesn't quite work yet due to the django-extra-views conflict of #7.  It
should start working once that issue is resolved.
e2ed0cd
Contributor

elbaschid commented Dec 6, 2012

I actually looked at that because I remembered that something had changed in a later version of django-extra-views. The reason I switch to 0.5.2 was that the get_inlines() method was introduced (line 21). However, I just realised that I didn't use it in the end so we could actually switch django-oscar-stores back to 0.2.2 to make it compatible with the current setup of Oscar.

How would you prefer to handle this?

As far as I know, I haven't introduced any backwards incompatible changes between 0.2.4 and 0.5.2. There's no reason why the Oscar requirement can't be changed to be >=0.2.4 and <= 0.5.2

Contributor

elbaschid commented Dec 20, 2012

This should be fixed with tangentlabs/django-oscar#407.

@elbaschid elbaschid closed this Dec 20, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment