Package is actually called `python-dateutil`, replace underscore with hyphen. #484

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
4 participants

rassie commented May 10, 2012

Even though pip, easy_install and PyPI also recognize the underscore, not every other possible tool in the chain does that (in my case, localshop, a local caching PyPI, failed to recognize the package).

Package is actually called `python-dateutil`, even though `pip`, `eas…
…y_install` and PyPI also recognize the underscore. However, not every other possible tool in the chain does that (in my case, `localshop`, a local caching PyPI, failed to recognize the package).

kmike commented May 10, 2012

distutils script can require package or module, not distribution. So I believe underscore is correct at least in 'require' section. See http://docs.python.org/distutils/setupscript.html#relationships-between-distributions-and-packages

Contributor

jezdez commented May 10, 2012

In that case dateutil would be correct, no?

kmike commented May 10, 2012

Yes, you're right.

@issackelly issackelly closed this in 2bad650 Jun 5, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment