Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixed Python 2.3 compatibility problem in [3872].

git-svn-id: http://code.djangoproject.com/svn/django/trunk@3874 bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
commit 0cc18151706d4f85e47b0171c63a63f51e0adcce 1 parent a834f21
@malcolmt malcolmt authored
Showing with 1 addition and 1 deletion.
  1. +1 −1  django/core/management.py
View
2  django/core/management.py
@@ -867,7 +867,7 @@ def get_validation_errors(outfile, app=None):
if settings.DATABASE_ENGINE == 'mysql':
db_version = connection.get_server_version()
if db_version < (5, 0, 3) and isinstance(f, (models.CharField, models.CommaSeparatedIntegerField, models.SlugField)) and f.maxlength > 255:
- e.add(opts, '"%s": %s cannot have a "maxlength" greater than 255 when you are using a version of MySQL prior to 5.0.3 (you are using %s).' % (f.name, f.__class__.__name__, '.'.join(str(n) for n in db_version[:3])))
+ e.add(opts, '"%s": %s cannot have a "maxlength" greater than 255 when you are using a version of MySQL prior to 5.0.3 (you are using %s).' % (f.name, f.__class__.__name__, '.'.join([str(n) for n in db_version[:3]])))
# Check to see if the related field will clash with any
# existing fields, m2m fields, m2m related objects or related objects
Please sign in to comment.
Something went wrong with that request. Please try again.