Permalink
Browse files

Fixed #22392 -- Corrected deployment instructions for Apache 2.4.

Thanks zjcheah at yahoo.com for the report.
  • Loading branch information...
1 parent 401be8a commit 0f37d2e4c0175d7b0ebe63e1146250437fc88cd0 @timgraham timgraham committed Apr 15, 2014
Showing with 4 additions and 6 deletions.
  1. +4 −6 docs/howto/deployment/wsgi/modwsgi.txt
@@ -26,7 +26,8 @@ Basic configuration
Once you've got mod_wsgi installed and activated, edit your Apache server's
``httpd.conf`` file and add the following. If you are using a version of Apache
-older than 2.4, replace ``Require all granted`` with ``Allow from all``.
+older than 2.4, replace ``Require all granted`` with ``Allow from all`` and
+also add the line ``Order deny,allow`` above it.
.. code-block:: apache
@@ -35,7 +36,6 @@ older than 2.4, replace ``Require all granted`` with ``Allow from all``.
<Directory /path/to/mysite.com/mysite>
<Files wsgi.py>
- Order deny,allow
Require all granted
</Files>
</Directory>
@@ -142,26 +142,24 @@ will be served using mod_wsgi::
Alias /static/ /path/to/mysite.com/static/
<Directory /path/to/mysite.com/static>
- Order deny,allow
Require all granted
</Directory>
<Directory /path/to/mysite.com/media>
- Order deny,allow
Require all granted
</Directory>
WSGIScriptAlias / /path/to/mysite.com/mysite/wsgi.py
<Directory /path/to/mysite.com/mysite>
<Files wsgi.py>
- Order allow,deny
Require all granted
</Files>
</Directory>
If you are using a version of Apache older than 2.4, replace
-``Require all granted`` with ``Allow from all``.
+``Require all granted`` with ``Allow from all`` and also add the line
+``Order deny,allow`` above it.
.. _lighttpd: http://www.lighttpd.net/
.. _Nginx: http://wiki.nginx.org/Main

0 comments on commit 0f37d2e

Please sign in to comment.