Permalink
Browse files

Fixed #18601 -- Specified that Python minimum version is 2.6.5

This is due to a bug in previous Python 2.6 versions related to
unicode keyword arguments.
  • Loading branch information...
1 parent 8c670ee commit 18b9dc41543616ba5b15d0400564e665b76701d1 @ptone ptone committed with claudep Jul 13, 2012
Showing with 8 additions and 8 deletions.
  1. +3 −3 docs/faq/install.txt
  2. +1 −1 docs/intro/install.txt
  3. +1 −1 docs/releases/1.5.txt
  4. +1 −1 docs/topics/install.txt
  5. +2 −2 docs/topics/logging.txt
View
@@ -16,8 +16,8 @@ How do I get started?
What are Django's prerequisites?
--------------------------------
-Django requires Python_, specifically Python 2.6 or 2.7.
-No other Python libraries are required for basic Django usage.
+Django requires Python_, specifically Python 2.6.5 - 2.7.x. No other Python
+libraries are required for basic Django usage.
For a development environment -- if you just want to experiment with Django --
you don't need to have a separate Web server installed; Django comes with its
@@ -42,7 +42,7 @@ Do I lose anything by using Python 2.6 versus newer Python versions, such as Pyt
----------------------------------------------------------------------------------------
Not in the core framework. Currently, Django itself officially supports
-Python 2.6 and 2.7. However, newer versions of
+Python 2.6 (2.6.5 or higher) and 2.7. However, newer versions of
Python are often faster, have more features, and are better supported. If you
use a newer version of Python you will also have access to some APIs that
aren't available under older versions of Python.
View
@@ -10,7 +10,7 @@ Install Python
--------------
Being a Python Web framework, Django requires Python. It works with any Python
-version from 2.6 to 2.7 (due to backwards incompatibilities in Python 3.0,
+version from 2.6.5 to 2.7 (due to backwards incompatibilities in Python 3.0,
Django does not currently work with Python 3.0; see :doc:`the Django FAQ
</faq/install>` for more information on supported Python versions and the 3.0
transition), these versions of Python include a lightweight database called
View
@@ -16,7 +16,7 @@ features`_.
Python compatibility
====================
-Django 1.5 has dropped support for Python 2.5. Python 2.6 is now the minimum
+Django 1.5 has dropped support for Python 2.5. Python 2.6.5 is now the minimum
required Python version. Django is tested and supported on Python 2.6 and
2.7.
View
@@ -9,7 +9,7 @@ Install Python
Being a Python Web framework, Django requires Python.
-It works with any Python version from 2.6 to 2.7 (due to backwards
+It works with any Python version from 2.6.5 to 2.7 (due to backwards
incompatibilities in Python 3.0, Django does not currently work with
Python 3.0; see :doc:`the Django FAQ </faq/install>` for more
information on supported Python versions and the 3.0 transition).
View
@@ -209,8 +209,8 @@ By default, Django uses the `dictConfig format`_.
``logging.dictConfig`` is a builtin library in Python 2.7. In
order to make this library available for users of earlier Python
versions, Django includes a copy as part of ``django.utils.log``.
- If you have Python 2.7, the system native library will be used; if
- you have Python 2.6 or earlier, Django's copy will be used.
+ If you have Python 2.7 or later, the system native library will be used; if
+ you have Python 2.6, Django's copy will be used.
In order to configure logging, you use :setting:`LOGGING` to define a
dictionary of logging settings. These settings describes the loggers,

0 comments on commit 18b9dc4

Please sign in to comment.