Permalink
Browse files

Fixed Python 2.4 incompatibility introduced in r15249.

git-svn-id: http://code.djangoproject.com/svn/django/trunk@15329 bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
1 parent 193f14d commit 33c155679cb283b31143df9389b06133c2bfeb20 @carljm carljm committed Jan 26, 2011
Showing with 2 additions and 1 deletion.
  1. +2 −1 django/db/models/deletion.py
@@ -10,7 +10,8 @@
class ProtectedError(IntegrityError):
def __init__(self, msg, protected_objects):
self.protected_objects = protected_objects
- super(ProtectedError, self).__init__(msg, protected_objects)
+ # TODO change this to use super() when we drop Python 2.4
+ IntegrityError.__init__(self, msg, protected_objects)
def CASCADE(collector, field, sub_objs, using):

0 comments on commit 33c1556

Please sign in to comment.