Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Added two admin login-related questions to the FAQ

git-svn-id: http://code.djangoproject.com/svn/django/trunk@132 bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
commit 364f3704b0cce0d147336ae2d9328ea95e152b63 1 parent 2b681e9
Adrian Holovaty authored July 17, 2005

Showing 1 changed file with 22 additions and 2 deletions. Show diff stats Hide diff stats

  1. 24  docs/faq.txt
24  docs/faq.txt
@@ -209,8 +209,28 @@ but we recognize that choosing a template language runs close to religion.
209 209
 There's nothing about Django that requires using the template language, so
210 210
 if you're attached to ZPT, Cheetah, or whatever, feel free to use those.
211 211
 
212  
-The admin interface
213  
-===================
  212
+The admin site
  213
+==============
  214
+
  215
+I can't log in. When I enter a valid username and password, it just brings up the login page again, with no error messages.
  216
+---------------------------------------------------------------------------------------------------------------------------
  217
+
  218
+The login cookie isn't being set correctly, because the domain of the cookie
  219
+sent out by Django doesn't match the domain in your browser. Try these two
  220
+things:
  221
+
  222
+* Set the ``REGISTRATION_COOKIE_DOMAIN`` setting to match your domain.
  223
+* Some browsers (Firefox?) don't like to accept cookies from domains that don't
  224
+  have dots in them. If you're running the admin site on "localhost" or another
  225
+  domain that doesn't have a dot in it, try going to "localhost.localdomain" or
  226
+  "127.0.0.1". And set ``REGISTRATION_COOKIE_DOMAIN`` accordingly.
  227
+
  228
+I can't log in. When I enter a valid username and password, it brings up the login page again, with a "Please enter a correct username and password" error.
  229
+-----------------------------------------------------------------------------------------------------------------------------------------------------------
  230
+
  231
+If you're sure your username and password are correct, make sure your user
  232
+account has ``is_active`` and ``is_staff`` set to True. The admin site only
  233
+allows access to users with those two fields both set to True.
214 234
 
215 235
 The dynamically-generated admin site is ugly! How can I change it?
216 236
 ------------------------------------------------------------------

0 notes on commit 364f370

Please sign in to comment.
Something went wrong with that request. Please try again.