Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Browse files

Add a note to the backwards-incompatible changes section of 1.4 relea…

…se notes about the change related to loading fixtures with incomplete data for auto_now and auto_now_add fields. Refs #12753. Thanks ptone.

git-svn-id: bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
1 parent d694f17 commit 37d04889108bb4334b873fa8b0b017343e15c5a1 @kmtracey kmtracey committed
Showing with 10 additions and 0 deletions.
  1. +10 −0 docs/releases/1.4.txt
10 docs/releases/1.4.txt
@@ -1078,6 +1078,16 @@ The internals of the tag aren't part of the official stable API, but in the
interests of full disclosure, the ``ExtendsNode.__init__`` definition has
changed, which may break any custom tags that use this class.
+Loading some incomplete fixtures no longer works
+Prior to 1.4, a default value was inserted for fixture objects that were missing
+a specific date or datetime value when auto_now or auto_now_add was set for the
+field. This was something that should not have worked, and in 1.4 loading such
+incomplete fixtures will fail. Because fixtures are a raw import, they should
+explicitly specify all field values, regardless of field options on the model.
Features deprecated in 1.4

0 comments on commit 37d0488

Please sign in to comment.
Something went wrong with that request. Please try again.