Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixed #9611 -- Noted in the FAQ answer about Python versions that som…

…e contrib apps (notably gis) may require a higher Python version. Thansk jamesivanwhite for the report and initial patch.

git-svn-id: bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
commit 5372508fdf4a853adbe54623bf85b440a552f1e8 1 parent 966f652
@kmtracey kmtracey authored
Showing with 4 additions and 2 deletions.
  1. +4 −2 docs/faq/install.txt
6 docs/faq/install.txt
@@ -48,8 +48,10 @@ PostgreSQL fans, and MySQL_, `SQLite 3`_, and Oracle_ are also supported.
Do I lose anything by using Python 2.3 versus newer Python versions, such as Python 2.5?
-No. Django itself is guaranteed to work with any version of Python from 2.3
-and higher.
+No, not in the core framework. Django itself is guaranteed to work with any
+version of Python from 2.3 and higher. However, some "django.contrib" add-on
+components may require a more recent Python release. The django.contrib.gis
+component, for example, requires Python 2.4.
If you use a Python version newer than 2.3, you will, of course, be able to
take advantage of newer Python features in your own code, along with the speed
Please sign in to comment.
Something went wrong with that request. Please try again.