Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Corrected expected test output to allow for cleanups in signal and co…

…mpatibility checks.
  • Loading branch information...
commit 6b63742ce5a63484890f147830d3fa9b2d0342f9 1 parent c41335f
@freakboy3742 freakboy3742 authored
View
4 django/core/checks/model_checks.py
@@ -31,9 +31,9 @@ def check_model_signals(app_configs=None, **kwargs):
# The receiver is either a function or an instance of class
# defining a `__call__` method.
if isinstance(receiver, types.FunctionType):
- description = "The `%s` function" % receiver.__name__
+ description = "The '%s' function" % receiver.__name__
else:
- description = "An instance of the `%s` class" % receiver.__class__.__name__
+ description = "An instance of the '%s' class" % receiver.__class__.__name__
errors.append(
Error(
"%s was connected to the '%s' signal "
View
2  tests/check_framework/tests.py
@@ -134,7 +134,7 @@ def test_boolean_field_default_value(self):
errors = check_1_6_compatibility()
expected = [
checks.Warning(
- 'BooleanField does not have a default value. ',
+ 'BooleanField does not have a default value.',
hint=('Django 1.6 changed the default value of BooleanField from False to None. '
'See https://docs.djangoproject.com/en/1.6/ref/models/fields/#booleanfield '
'for more information.'),
View
6 tests/model_validation/tests.py
@@ -32,7 +32,7 @@ def test_model_signal(self):
errors = run_checks()
expected = [
Error(
- "The `on_post_init` function was connected to the `post_init` "
+ "The 'on_post_init' function was connected to the 'post_init' "
"signal with a lazy reference to the 'missing-app.Model' "
"sender, which has not been installed.",
hint=None,
@@ -40,8 +40,8 @@ def test_model_signal(self):
id='signals.E001',
),
Error(
- "An instance of the `OnPostInit` class was connected to "
- "the `post_init` signal with a lazy reference to the "
+ "An instance of the 'OnPostInit' class was connected to "
+ "the 'post_init' signal with a lazy reference to the "
"'missing-app.Model' sender, which has not been installed.",
hint=None,
obj='model_validation.tests',
Please sign in to comment.
Something went wrong with that request. Please try again.