Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Removed mentions of Python 2.3 support from the docs -- Django 1.2 dr…

…ops support for Python 2.3 -- and added a quick FAQ about that dropping of support.

git-svn-id: http://code.djangoproject.com/svn/django/trunk@11640 bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
commit 7098664940567c772a45ad98f9ee936063a1102e 1 parent 8be1bb2
@jacobian jacobian authored
View
15 docs/faq/install.txt
@@ -18,7 +18,7 @@ How do I get started?
What are Django's prerequisites?
--------------------------------
-Django requires Python_, specifically any version of Python from 2.3
+Django requires Python_, specifically any version of Python from 2.4
through 2.6. No other Python libraries are required for basic Django
usage.
@@ -42,11 +42,11 @@ PostgreSQL fans, and MySQL_, `SQLite 3`_, and Oracle_ are also supported.
.. _`SQLite 3`: http://www.sqlite.org/
.. _Oracle: http://www.oracle.com/
-Do I lose anything by using Python 2.3 versus newer Python versions, such as Python 2.5?
+Do I lose anything by using Python 2.4 versus newer Python versions, such as Python 2.5 or 2.6?
----------------------------------------------------------------------------------------
Not in the core framework. Currently, Django itself officially
-supports any version of Python from 2.3 through 2.6,
+supports any version of Python from 2.4 through 2.6,
inclusive. However, some add-on components may require a more recent
Python version; the ``django.contrib.gis`` component, for example,
requires at least Python 2.4, and third-party applications for use
@@ -59,10 +59,17 @@ which will end with Django running on Python 3.0 (see next question
for details). So if you're just starting out with Python, it's
recommended that you use the latest 2.x release (currently, Python
2.6). This will let you take advantage of the numerous improvements
-and optimizations to the Python language since version 2.3, and will
+and optimizations to the Python language since version 2.4, and will
help ease the process of dropping support for older Python versions on
the road to Python 3.0.
+Can I use Django with Python 2.3?
+---------------------------------
+
+Django 1.1 (and earlier) supported Python 2.3. Django 1.2 and newer does not.
+We highly recommend you upgrade Python if at all possible, but Django 1.1 will
+continue to work on Python 2.3.
+
Can I use Django with Python 3.0?
---------------------------------
View
2  docs/intro/install.txt
@@ -12,7 +12,7 @@ Install Python
--------------
Being a Python Web framework, Django requires Python. It works with any Python
-version from 2.3 to 2.6 (due to backwards
+version from 2.4 to 2.6 (due to backwards
incompatibilities in Python 3.0, Django does not currently work with
Python 3.0; see :ref:`the Django FAQ <faq-install>` for more
information on supported Python versions and the 3.0 transition), but we recommend installing Python 2.5 or later. If you do so, you won't need to set up a database just yet: Python 2.5 or later includes a lightweight database called SQLite_.
View
10 docs/topics/auth.txt
@@ -1046,15 +1046,7 @@ checks to make sure the user is logged in and has the permission
optional ``login_url`` argument, which lets you specify the URL for your
login page (:setting:`settings.LOGIN_URL <LOGIN_URL>` by default).
- Example in Python 2.3 syntax::
-
- from django.contrib.auth.decorators import user_passes_test
-
- def my_view(request):
- # ...
- my_view = user_passes_test(lambda u: u.has_perm('polls.can_vote'), login_url='/login/')(my_view)
-
- Example in Python 2.4 syntax::
+ For example::
from django.contrib.auth.decorators import user_passes_test
View
6 docs/topics/cache.txt
@@ -616,12 +616,6 @@ like so::
from django.views.decorators.vary import vary_on_headers
- # Python 2.3 syntax.
- def my_view(request):
- # ...
- my_view = vary_on_headers(my_view, 'User-Agent')
-
- # Python 2.4+ decorator syntax.
@vary_on_headers('User-Agent')
def my_view(request):
# ...
View
7 docs/topics/conditional-view-processing.txt
@@ -95,13 +95,6 @@ for your front page view::
def front_page(request, blog_id):
...
-Of course, if you're using Python 2.3 or prefer not to use the decorator
-syntax, you can write the same code as follows, there is no difference::
-
- def front_page(request, blog_id):
- ...
- front_page = condition(last_modified_func=latest_entry)(front_page)
-
Shortcuts for only computing one value
======================================
View
4 docs/topics/install.txt
@@ -11,7 +11,7 @@ Install Python
Being a Python Web framework, Django requires Python.
-It works with any Python version from 2.3 to 2.6 (due to backwards
+It works with any Python version from 2.4 to 2.6 (due to backwards
incompatibilities in Python 3.0, Django does not currently work with
Python 3.0; see :ref:`the Django FAQ <faq-install>` for more
information on supported Python versions and the 3.0 transition).
@@ -93,7 +93,7 @@ database bindings are installed.
will also want to read the database-specific notes for the :ref:`MySQL
backend <ref-databases>`.
-* If you're using SQLite and either Python 2.3 or Python 2.4, you'll need
+* If you're using SQLite and either Python 2.4 or Python 2.4, you'll need
pysqlite_. Use version 2.0.3 or higher. Python 2.5 ships with an SQLite
wrapper in the standard library, so you don't need to install anything extra
in that case. Please read the SQLite backend :ref:`notes<sqlite-notes>`.
Please sign in to comment.
Something went wrong with that request. Please try again.