Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixed GMLv3 output test failure on PostGIS versions < 1.5.

  • Loading branch information...
commit 84f9741664dadb3185c3d8822b720b340374066e 1 parent 5a64bd3
Justin Bronn jbronn authored
Showing with 4 additions and 2 deletions.
  1. +4 −2 django/contrib/gis/tests/geoapp/tests.py
6 django/contrib/gis/tests/geoapp/tests.py
View
@@ -529,8 +529,10 @@ def test_gml(self):
for ptown in [ptown1, ptown2]:
self.assertTrue(gml_regex.match(ptown.gml))
- if postgis:
- self.assertIn('<gml:pos srsDimension="2">', City.objects.gml(version=3).get(name='Pueblo').gml)
+ # PostGIS < 1.5 doesn't include dimension im GMLv3 output.
+ if postgis and connection.ops.spatial_version >= (1, 5, 0):
+ self.assertIn('<gml:pos srsDimension="2">',
+ City.objects.gml(version=3).get(name='Pueblo').gml)
def test_kml(self):
"Testing KML output from the database using GeoQuerySet.kml()."
Please sign in to comment.
Something went wrong with that request. Please try again.