Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Emphasized MyISAM pseudo-requirement for GeoDjango over MySQL

Refs #15295.
  • Loading branch information...
commit 8fbc20b24bd14e22f3d9c0dd02781ddf1f2b5bd7 1 parent 604d876
@claudep claudep authored
Showing with 3 additions and 3 deletions.
  1. +3 −3 docs/ref/contrib/gis/install/index.txt
View
6 docs/ref/contrib/gis/install/index.txt
@@ -46,8 +46,8 @@ how to install.
Spatial database
----------------
-PostgreSQL (with PostGIS), MySQL, Oracle, and SQLite (with SpatiaLite) are
-the spatial databases currently supported.
+PostgreSQL (with PostGIS), MySQL (mostly with MyISAM engine), Oracle, and SQLite
+(with SpatiaLite) are the spatial databases currently supported.
.. note::
@@ -62,7 +62,7 @@ supported versions, and any notes for each of the supported database backends:
Database Library Requirements Supported Versions Notes
================== ============================== ================== =========================================
PostgreSQL GEOS, PROJ.4, PostGIS 8.2+ Requires PostGIS.
-MySQL GEOS 5.x Not OGC-compliant; limited functionality.
+MySQL GEOS 5.x Not OGC-compliant; :ref:`limited functionality <mysql-spatial-limitations>`.
Oracle GEOS 10.2, 11 XE not supported; not tested with 9.
SQLite GEOS, GDAL, PROJ.4, SpatiaLite 3.6.+ Requires SpatiaLite 2.3+, pysqlite2 2.5+
================== ============================== ================== =========================================
Please sign in to comment.
Something went wrong with that request. Please try again.