Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Bumped minimum Python version requirement to 2.7 in Django 1.7.

  • Loading branch information...
commit a763915a03579868c6abdc5cdffbb4c398dc52ee 1 parent 3fd8eb1
Aymeric Augustin aaugustin authored
3  INSTALL
View
@@ -1,6 +1,6 @@
Thanks for downloading Django.
-To install it, make sure you have Python 2.6 or greater installed. Then run
+To install it, make sure you have Python 2.7 or greater installed. Then run
this command from the command prompt:
python setup.py install
@@ -12,7 +12,6 @@ site-packages directory, which is located wherever your Python installation
lives. Some places you might check are:
/usr/lib/python2.7/site-packages (Unix, Python 2.7)
- /usr/lib/python2.6/site-packages (Unix, Python 2.6)
C:\\PYTHON\site-packages (Windows)
For more detailed instructions, see docs/intro/install.txt.
8 docs/faq/install.txt
View
@@ -16,8 +16,8 @@ How do I get started?
What are Django's prerequisites?
--------------------------------
-Django requires Python, specifically Python 2.6.5 - 2.7.x, or 3.2.3 and above.
-No other Python libraries are required for basic Django usage.
+Django requires Python, specifically Python 2.7 or 3.2 and above. No other
+Python libraries are required for basic Django usage.
For a development environment -- if you just want to experiment with Django --
you don't need to have a separate Web server installed; Django comes with its
@@ -50,8 +50,8 @@ Django version Python versions
1.3 2.4, 2.5, 2.6, 2.7
1.4 2.5, 2.6, 2.7
1.5 2.6, 2.7 and 3.2, 3.3 (experimental)
-**1.6** **2.6, 2.7** and **3.2, 3.3**
-*1.7 (future)* *2.7* and *3.2, 3.3*
+1.6 2.6, 2.7 and 3.2, 3.3
+**1.7** **2.7** and **3.2, 3.3**
============== ===============
For a given series of Python versions, only the latest release is officially
10 docs/intro/install.txt
View
@@ -9,9 +9,9 @@ that'll work while you walk through the introduction.
Install Python
--------------
-Being a Python Web framework, Django requires Python. It works with Python 2.6,
-2.7, 3.2 or 3.3. All these versions of Python include a lightweight database
-called SQLite_ so you won't need to set up a database just yet.
+Being a Python Web framework, Django requires Python. It works with Python 2.7,
+3.2 or 3.3. All these versions of Python include a lightweight database called
+SQLite_ so you won't need to set up a database just yet.
.. _sqlite: http://sqlite.org/
@@ -28,8 +28,8 @@ probably already have it installed.
You can verify that Python is installed by typing ``python`` from your shell;
you should see something like::
- Python 2.6.6 (r266:84292, Dec 26 2010, 22:31:48)
- [GCC 4.4.5] on linux2
+ Python 2.7.3 (default, Jan 2 2013, 13:56:14)
+ [GCC 4.7.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
4 docs/topics/install.txt
View
@@ -7,8 +7,8 @@ This document will get you up and running with Django.
Install Python
==============
-Being a Python Web framework, Django requires Python. It works with Python 2.6,
-2.7, 3.2 or 3.3.
+Being a Python Web framework, Django requires Python. It works with Python 2.7,
+3.2 or 3.3.
Get Python at http://www.python.org. If you're running Linux or Mac OS X, you
probably already have it installed.
1  setup.py
View
@@ -101,7 +101,6 @@ def is_package(package_name):
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
Please sign in to comment.
Something went wrong with that request. Please try again.