Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixed #9783; clarified install docs and FAQ to explain that Django do…

…es not yet work with Python 3.0.

git-svn-id: http://code.djangoproject.com/svn/django/trunk@9628 bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
commit adfad3c19340d1a97c0d8c16a563b81b3f87faca 1 parent b4364e0
@ubernostrum ubernostrum authored
Showing with 37 additions and 11 deletions.
  1. +34 −10 docs/faq/install.txt
  2. +3 −1 docs/topics/install.txt
View
44 docs/faq/install.txt
@@ -43,16 +43,40 @@ PostgreSQL fans, and MySQL_, `SQLite 3`_, and Oracle_ are also supported.
Do I lose anything by using Python 2.3 versus newer Python versions, such as Python 2.5?
----------------------------------------------------------------------------------------
-No, not in the core framework. Django itself is guaranteed to work with any
-version of Python from 2.3 and higher. However, some "django.contrib" add-on
-components may require a more recent Python release. The django.contrib.gis
-component, for example, requires Python 2.4.
-
-If you use a Python version newer than 2.3, you will, of course, be able to
-take advantage of newer Python features in your own code, along with the speed
-improvements and other optimizations that have been made to the Python language
-itself. But the Django framework itself should work equally well on 2.3 as it
-does on 2.4 or 2.5.
+Not in the core framework. Currently, Django itself officially
+supports any version of Python from 2.3 through 2.6,
+inclusive. However, some add-on components may require a more recent
+Python version; the ``django.contrib.gis`` component, for example,
+requires at least Python 2.4, and third-party applications for use
+with Django are, of course, free to set their own version
+requirements.
+
+Please note, however, that over the next year or two Django will begin
+dropping support for older Python versions as part of a migration
+which will end with Django running on Python 3.0 (see next question
+for details). So if you're just starting out with Python, it's
+recommended that you use the latest 2.x release (currently, Python
+2.6). This will let you take advantage of the numerous improvements
+and optimizations to the Python language since version 2.3, and will
+help ease the process of dropping support for older Python versions on
+the road to Python 3.0.
+
+Can I use Django with Python 3.0?
+---------------------------------
+
+Not at the moment. Python 3.0 introduced a number of
+backwards-incompatible changes to the Python language, and although
+these changes are generally a good thing for Python's future, it will
+be a while before most Python software catches up and is able to run
+on Python 3.0. For larger Python-based software like Django, the
+transition is expected to take at least a year or two (since it
+involves dropping support for older Python releases and so must be
+done gradually).
+
+In the meantime, Python 2.x releases will be supported and provided
+with bug fixes and security updates by the Python development team, so
+continuing to use a Python 2.x release during the transition should
+not present any risk.
Do I have to use mod_python?
----------------------------
View
4 docs/topics/install.txt
@@ -11,7 +11,9 @@ Install Python
Being a Python Web framework, Django requires Python.
-It works with any Python version 2.3 and higher.
+It works with any Python version from 2.3 to 2.6 (due to backwards
+incompatibilities in Python 3.0, Django does not currently work with
+Python 3.0 and likely will not for some time to come).
Get Python at http://www.python.org. If you're running Linux or Mac OS X, you
probably already have it installed.
Please sign in to comment.
Something went wrong with that request. Please try again.