Permalink
Browse files

Added notes about `select_for_update` to the 1.4 release notes.

git-svn-id: http://code.djangoproject.com/svn/django/trunk@16059 bcc190cf-cafb-0310-a4f2-bffc1f526a37
  • Loading branch information...
jacobian committed Apr 20, 2011
1 parent 8f0f73c commit c92e0e47657f8c53673523428011f34ba15be7bb
Showing with 12 additions and 1 deletion.
  1. +12 −1 docs/releases/1.4.txt
View
@@ -13,10 +13,21 @@ which are detailed in :doc:`our deprecation plan </internals/deprecation>`.
.. _new features: `What's new in Django 1.4`_ .. _new features: `What's new in Django 1.4`_
.. _backwards incompatible changes: backwards-incompatible-changes-1.4_ .. _backwards incompatible changes: backwards-incompatible-changes-1.4_
What's new in Django 1.4 What's new in Django 1.4
======================== ========================
``SELECT FOR UPDATE`` support
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Django 1.4 now includes a :meth:`QuerySet.select_for_update()
<django.db.models.query.QuerySet.select_for_update>` method which generates a
``SELECT ... FOR UPDATE`` SQL query. This will lock rows until the end of the
transaction, meaning that other transactions cannot modify or delete rows
matched by a ``FOR UPDATE`` query.
For more details, see the documentation for
:meth:`~django.db.models.query.QuerySet.select_for_update`.
.. _backwards-incompatible-changes-1.4: .. _backwards-incompatible-changes-1.4:
Backwards incompatible changes in 1.4 Backwards incompatible changes in 1.4

0 comments on commit c92e0e4

Please sign in to comment.