Permalink
Browse files

Updates to the README.

  • Loading branch information...
1 parent 6c4edeb commit 6ed5ca95eabfe43b8439e8a43638cb28c12fd8da @djberg96 committed Feb 23, 2012
Showing with 6 additions and 0 deletions.
  1. +6 −0 README
View
6 README
@@ -6,6 +6,8 @@
MS Windows when using the Net::Ping::External class unless you're
using JRuby.
+ JRuby users should use 1.6.7 or later.
+
== Installation
gem install net-ping
@@ -34,9 +36,13 @@
== Known Issues
Older versions of Ruby 1.9.x may not work with UDP pings.
+
Older versions of JRuby will return false positives in UDP pings
because of an incorrect error class being raised. See JRuby-4896.
+ JRuby 1.6.7 or later is required for external pings because of a bug
+ in earlier versions with open3 and stream handling.
+
== License
Artistic 2.0

0 comments on commit 6ed5ca9

Please sign in to comment.