Permalink
Browse files

Windows dependency change and a minor update for win32-security.

  • Loading branch information...
1 parent 1a64980 commit d8b21fef84571878816703b27d174f9c07d5a09f @djberg96 committed Jan 24, 2013
Showing with 3 additions and 5 deletions.
  1. +1 −1 net-ping.gemspec
  2. +2 −4 test/test_net_ping.rb
View
@@ -28,7 +28,7 @@ Gem::Specification.new do |spec|
spec.platform.version = nil
# Used primarily for icmp pings.
- spec.add_development_dependency('win32-security', '>= 1.0.8')
+ spec.add_development_dependency('win32-security', '>= 0.2.0')
if RUBY_VERSION.to_f < 1.9
spec.add_dependency('win32-open3', '>= 0.3.1')
View
@@ -12,10 +12,8 @@
if File::ALT_SEPARATOR
require 'win32/security'
- require 'windows/system_info'
- include Windows::SystemInfo
- if windows_version >= 6 && Win32::Security.elevated_security?
+ if Win32::Security.elevated_security?
require 'test_net_ping_icmp'
end
else
@@ -30,7 +28,7 @@
class TC_Net_Ping < Test::Unit::TestCase
def test_net_ping_version
- assert_equal('1.5.2', Net::Ping::VERSION)
+ assert_equal('1.5.3', Net::Ping::VERSION)
end
end

0 comments on commit d8b21fe

Please sign in to comment.