Browse files

Once again don't allow installation if gnuplot isn't installed

This is more for CPAN-testers than anything else
  • Loading branch information...
1 parent 7beb45b commit 835606b09f900c6f9ea36e6a7dbafd93353f65df @dkogan committed Aug 5, 2012
Showing with 9 additions and 6 deletions.
  1. +9 −6 Makefile.PL
View
15 Makefile.PL
@@ -18,20 +18,23 @@ sub parseversion
return $version;
}
-# make sure we can run gnuplot
+# make sure we can run gnuplot before continuing
{
unless( open( my $pipe, '|-', 'gnuplot' ))
{
print STDERR <<EOM;
Error: "$!"
-I tried to execute 'gnuplot' and it didn't work. Since this module is an
-interface to Gnuplot, it must be installed for the module to be useful. I'll go
-ahead and build PDL::Graphics::Gnuplot, but it'll be useless without gnuplot.
-THE UNIT TESTS WILL FAIL until gnuplot is installed. Use your package manager,
-or download the source from http://www.gnuplot.info
+I tried to execute 'gnuplot' and it didn't work. Since this module is an is an
+interface to Gnuplot, it must be installed for the module to be useful. Install
+Gnuplot to continue. Use your package manager, or download the source from
+http://www.gnuplot.info
EOM
+
+ # This exit is mostly for cpan testers to not tell me that my module is
+ # broken
+ exit 0;
}
}

0 comments on commit 835606b

Please sign in to comment.