GNS3 Packaging for Debian
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
broker
debian
docs/man
qemuwrapper
src/GNS3
vboxwrapper
.gitignore
.hgignore
AUTHORS
CHANGELOG
COPYING
GNS3.e4p
README
TODO
baseconfig.txt
baseconfig_sw.txt
gns3
gns3.icns
gns3.pyw
securecrt.vbs
setup.py
stdeb.cfg
style.pl
ttstart.macro

README

INSTALLATION

* GNS3 dependencies:

- Qt 4.5.1 (or higher)
- Python 2.6 (or higher)
- Sip 4.5 (or higher)
- PyQt 4.5 (or higher)
- Dynamips 0.2.8+
- VirtualBox 4.1.x
- QEMU 1.1+
- PEMU
- xdotool (on X11 UNIX-like platforms)
- Wireshark

* WINDOWS users:

Download the GNS3 all-in-one for Windows on http://www.gns3.net
This program will install a binary version of GNS3 as well as Dynamips, Qemu and WinPCAP.

Recommendation: Dynamips has better performances on other platforms such as Linux or Mac OS X.

* Linux users:

On Linux you just need to install a package called python-qt4 (or similar). Instead, you can compile all the dependencies manually.

You can run GNS3 from the source directory or install it using the following command:

python setup.py install

* MacOS X users:

Method 1.

1. Install the Apple Devs Tools (on your Mac OS X DvD or download it on ADC account). Run and install XcodeTools.mpkg.

2. Download Python 2.6 for MacOS X on http://www.python.org/download/ and install it.

3. Download Qt librairies for Mac on http://qt.nokia.com/downloads and install it.

4. Download SIP on http://www.riverbankcomputing.com/software/sip/download, compile and install it:

	Open terminal and cd into the folder you downloaded the tar file and compile via the following commands (example for SIP 4.9.3):

	Macintosh:$  tar xvzf sip-4.9.3.tar.gz
	Macintosh:$  cd sip-4.9.3
	Macintosh:sip-4.9.3$  python configure.py
	Macintosh:sip-4.9.3$  make
	Macintosh:sip-4.9.3$  make install

5. Download PyQt on http://www.riverbankcomputing.com/software/pyqt/download, compile and install it:

	Again, run the following commands to decompress and compile PyQt (example for PyQt 4.6.2):

	Macintosh:$  tar xvzf PyQt-mac-gpl-4.6.2.tar.gz
	Macintosh:$  cd PyQt-mac-gpl-4.6.2
	Macintosh:PyQt-mac-gpl-4.6.2$  python configure.py
	Macintosh:PyQt-mac-gpl-4.6.2$  make
	Macintosh:PyQt-mac-gpl-4.6.2$  make install

6. Download and start GNS3.


Method 2 (this can take a few hours as everything is compiled).

1. Download and install MacPorts http://guide.macports.org/#installing (you will need the Apple Devs Tools).

2. Open a terminal and install GNS3 dependencies.

	Macintosh:$ sudo port install python26
	Macintosh:$ sudo port install py26-sip
	Macintosh:$ sudo port install py26-pyqt4
	Macintosh:$ sudo port install qt4-mac

	Optionnal: to prevent MacPorts to install the last version of the dependencies (which may not work properly with GNS3), you can force a specified version with @.

	Example:

	Macintosh:$ sudo port install python26
	Macintosh:$ sudo port install py26-sip @4.9.3_0
	Macintosh:$ sudo port install py26-pyqt4 @4.6.2_0
	Macintosh:$ sudo port install qt4-mac @4.5.3_0

3. Download and start GNS3