New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

READ THIS IF YOU WANT HELP #238

Open
Varbin opened this Issue Aug 29, 2017 · 0 comments

Comments

Projects
None yet
1 participant
@Varbin
Copy link

Varbin commented Aug 29, 2017

tl;dr: PyCrypto is dead. Switch to PyCryptodome (GitHub: https://github.com/Legrandin/pycryptodome PyPi: https://pypi.python.org/pypi/pycryptodome). Do not report any new bugs here!


As you may or may not have noticed the last change to PyCrypto was made three years ago.

As a result the developers don't react to issues on the issue tracker anymore. If you find problems and want them to be fixed consider following:

As a user or developer who uses software which requires PyCrypto:

  • Tell this to your application's developer to switch to PyCryptodome and tell them PyCrypto is dead.

As a developer who develops/maintains software depending on PyCrypto:

  • Consider switching to Pycryptodome - it's a well mantained fork and mostly compatible. If your problems persists report your problem to Pycryptodome's developer.

As a developer who wants to develop new software:

  • Do not use Pycrypto! Use Pycrpytodome or cryptography. PyCrypto is old and not maintained.

While this is not an official statement it represents the status quo.

aphor added a commit to aphor/salt that referenced this issue Jun 2, 2018

zeromq dependency: pycrypto --> cryptodome
I was unable to pip install pycrypto because of an autoconf error, and found

This
dlitz/pycrypto#168

which led me to  this
`tl;dr: PyCrypto is dead. Switch to PyCryptodome (GitHub: https://github.com/Legrandin/pycryptodome PyPi: https://pypi.python.org/pypi/pycryptodome). Do not report any new bugs here!`
dlitz/pycrypto#238

aphor added a commit to aphor/salt that referenced this issue Jun 3, 2018

zeromq dependency: pycrypto --> cryptodome
I was unable to pip install pycrypto because of an autoconf error, and found

This
dlitz/pycrypto#168

which led me to  this
`tl;dr: PyCrypto is dead. Switch to PyCryptodome (GitHub: https://github.com/Legrandin/pycryptodome PyPi: https://pypi.python.org/pypi/pycryptodome). Do not report any new bugs here!`
dlitz/pycrypto#238

Nikratio added a commit to s3ql/s3ql that referenced this issue Jan 14, 2019

Use cryptography instead of pycrypto
pycrypto seems to be unmaintained these days
(cf. dlitz/pycrypto#238).

Fixes: #65.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment