Home

dlitz edited this page Sep 13, 2010 · 3 revisions
Clone this wiki locally

This is a forked repository. Have a look at
sunaku’s ruby-vpi wiki
for more information.

Issues

  • Doesn’t load from rubygems. Setting RUBYLIB to point to $GEM_HOME/ruby-vpi-*/{lib,obj} seems to help. Without that, I get:
    [user.c:23] Ruby-VPI: error: rb_require(‘ruby-vpi/boot/relay’) failed with status 6
    [user.c:23] Ruby-VPI: error: rb_require(‘ruby-vpi/boot/loader’) failed with status 6
    ruby: uninitialized constant RubyVPI (NameError)
    ruby: [BUG] Segmentation fault
    ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-linux]
  • Then, I get " ArgumentError: “VpiHigh” is not a valid VPI property". Fix here:
    http://rubyforge.org/pipermail/ruby-vpi-discuss/2008-March/000089.html