Skip to content

Releases: dlmanning/gulp-sass

v5.1.0

Compare
Choose a tag to compare

Huge shout out to @XhmikosR for putting a ton of effort into this release 🎉

What's Changed

New Contributors

Full Changelog: v5.0.0...v5.1.0

v5.0.0

978b8f6
Compare
Choose a tag to compare

First and foremost a huge shout out to @mxmason for making this long awaited release possible <3

Breaking changes

  • Require Node >= 12
  • Require Gulp 4
  • Drop dependency on the deprecate node-sass
  • Remove hardcoded default Sass compiler

Upgrading to v5

It is now required to explicitly install a Sass compiler.

npm install gulp-sass sass

or to continue using node-sass

npm install gulp-sass node-sass

Gulp tasks will also need to be update to use the installed Sass compiler

const sass = require('gulp-sass')(require('sass'));

Check out the upgrade guide for more details.

v4.1.1

Compare
Choose a tag to compare

Dependencies

  • Bump lodash@^4.17.20 (@Larinar, #776)

v4.1.0

Compare
Choose a tag to compare

Features

Dependencies

  • Migrate to the lodash package (@stof, #728)

v4.0.2

Compare
Choose a tag to compare

Documentation

  • Document how to use Dart Sass (@nex3, #672)

v4.0.1

Compare
Choose a tag to compare

Fixes

v4.0.0

Compare
Choose a tag to compare

This release is remove our dependency on the deprecated gulp-util package. To do so we need to drop support for Node < 4.

We took this opportunity to update our support policy to match the upcoming Node Sass 5 release. From now on Gulp Sass will only support Active LTS and Current Node versions.

At the time of release this means Node ^6.9 || ^8.9 || ^9 || ^10.

Breaking changes

Misc

v3.2.1

04fb925
Compare
Choose a tag to compare

Features

  • Bump minimum node-sass to 4.8.3 (@xzyfer)

v3.2.0

Compare
Choose a tag to compare

Features

  • Bump minimum node-sass to 4.8.1 (@xzyfer)

Maintainence

Fixes

v3.1.0