Permalink
Fetching contributors…
Cannot retrieve contributors at this time
50 lines (35 sloc) 1.06 KB
Xournal Installation instructions
=================================
Dependencies:
-------------
Required packages and libraries:
* TO COMPILE xournal:
- autoconf, automake (to generate the makefiles)
- gtk+ 2.10 or later development packages
(package gtk2-devel and its dependencies)
- libgnomecanvas 2.4 or later development packages
(package libgnomecanvas-devel and its dependencies)
- poppler-glib 0.5.4 or later development packages
(package poppler-glib-devel and dependencies)
* TO RUN xournal:
- gtk+ 2.10 or later
(package gtk2 and dependencies)
- libgnomecanvas 2.4 or later
(package libgnomecanvas and dependencies)
- poppler-glib 0.5.4 or later
(package poppler-glib and dependencies)
* OTHER:
- ghostscript (optional: used to import PS/PDF files as bitmap backgrounds)
Compilation and installation:
-----------------------------
Installation in /usr/local:
./autogen.sh
make
(as root) make install
(as root) make desktop-install
Installation in $HOME:
./autogen.sh
./configure --prefix=$HOME
make
make install
make home-desktop-install