New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Chroot asking for password that I did NOT set [Solved] #2050

Closed
adhoc92 opened this Issue Aug 30, 2015 · 32 comments

Comments

Projects
None yet
@adhoc92
Copy link

adhoc92 commented Aug 30, 2015

I just bought a new Chromebook. I downloaded Chrouton and typed "sudo sh ~/Downloads/crouton -t xfce" into Crosh > Shell.

Then I received the following message:

" We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

  1. Respect the privacy of others.
  2. Think before you type.
  3. With great power comes great responsibility.

Password: "

I've tried every password I can think of with no success. Any ideas?

@DennisLfromGA

This comment has been minimized.

Copy link
Collaborator

DennisLfromGA commented Aug 30, 2015

By default, there is no password for chronos or root so if one is set, you'll have to remove it.

Before installing a new chroot or anything else, it might be best if you saved everything you need in ~/Downloads, etc. and do a 'powerwash'.
You can access 'powerwash' from Advanced settings or press Ctrl+Alt+Shift+R from the sign-in screen.

@adhoc92

This comment has been minimized.

Copy link
Author

adhoc92 commented Aug 30, 2015

I have powerwashed several times. After each wash, I have enabled developer settings. Crosh > shell still asks me for a password after any Sudo command.

Edit: My chromebook is an Acer Cb3-111.

@tcagle

This comment has been minimized.

Copy link

tcagle commented Aug 30, 2015

You should read the sudo man page or google sudo and read what it does.
Sounds like normal behavior to me.

On Sun, Aug 30, 2015 at 2:40 PM, adhoc92 notifications@github.com wrote:

I have powerwashed several times. After each wash, I have enabled
developer settings. Crosh > shell still asks me for a password after any
Sudo command.


Reply to this email directly or view it on GitHub
#2050 (comment).

@adhoc92

This comment has been minimized.

Copy link
Author

adhoc92 commented Aug 30, 2015

I just finished reading the manual. I don't see anything that will help me. I have found a few ways to change the password, but I need Sudo access to do so.

@tcagle

This comment has been minimized.

Copy link

tcagle commented Aug 30, 2015

If memory serves (big if) there is a default password for the sudo
(chronos) login and it is documented on the crouton website.

On Sun, Aug 30, 2015 at 4:21 PM, adhoc92 notifications@github.com wrote:

I just finished reading the manual. I don't see anything that will help
me. I have found a few ways to change the password, but I need Sudo access
to do so.


Reply to this email directly or view it on GitHub
#2050 (comment).

@DennisLfromGA

This comment has been minimized.

Copy link
Collaborator

DennisLfromGA commented Aug 30, 2015

I just bought a new Chromebook.

If that's the case, I don't see how you could have anything other than the 'stock' Chrome OS.
But, if a powerwash doesn't do it, then you may need to use the 'Chromebook Recovery Utility'.

@adhoc92

This comment has been minimized.

Copy link
Author

adhoc92 commented Aug 30, 2015

Dennis, I have done that as well :/ Same result.

@adhoc92

This comment has been minimized.

Copy link
Author

adhoc92 commented Aug 30, 2015

SOLVED.

I fixed it by NOT enabling debug features on the setup screen.

So if any future adventurers with an Acer CB3-111 Chromebook have the same problem, that should (hopefully) work.

@DennisLfromGA

This comment has been minimized.

Copy link
Collaborator

DennisLfromGA commented Aug 30, 2015

I fixed it by NOT enabling debug features on the setup screen.

Well I'd say that was an important omission.

See *Debugging Features

Click Proceed. The system reboots and displays a dialog with password prompts
[OPTIONAL] Set the new root password.
Note: If you leave the root password blank, the password defaults to test0000.

@adhoc92

This comment has been minimized.

Copy link
Author

adhoc92 commented Aug 31, 2015

Yeah, that's my my bad. I thought it was a normal part of the process that went without saying. That was obviously NOT the case. Thanks for sticking around and helping me out guys!

@adhoc92 adhoc92 changed the title Chroot asking for password that I did NOT set Chroot asking for password that I did NOT set [Solved] Aug 31, 2015

@tedm

This comment has been minimized.

Copy link
Contributor

tedm commented Aug 31, 2015

k, so now we know you're not crazy ;)

@dnschneid dnschneid closed this Sep 16, 2015

@dnschneid dnschneid added the question label Sep 16, 2015

@billunique

This comment has been minimized.

Copy link

billunique commented Dec 22, 2016

Thanks, this is just what I am finding.

@DennisLfromGA

This comment has been minimized.

Copy link
Collaborator

DennisLfromGA commented Dec 22, 2016

There seems to be a glitch in setting up the Debugging features in CrOS that leads to this issue. I don't know if it's a WAI (works as intended) thing or not but it can throw a kink in things if you're not aware of it.
This thread talks about it and has a workaround for it too - #2927 (comment)

Hope this helps,
-DennisL

@scottdavisxx

This comment has been minimized.

Copy link

scottdavisxx commented May 17, 2017

I just ran into the same problem. It turns out. it is not asking for your password to download. It is asking you to create a password. If you type in a password of your choice and then confirm that same password. It will then ask for another password to be created. I used the same password.

I followed this guide. https://www.lifewire.com/install-linux-on-chromebook-4125253

This is how they describe this process.
"You may now be prompted to provide and verify both a password and an encryption passphrase at this juncture, the reason being that you chose to encrypt your Ubuntu installation via the "-e" parameter in the previous step. While this flag is not required, it is highly recommended. Choose a secure password and passphrase that you will remember and enter them accordingly, if applicable."

@ollie05w

This comment has been minimized.

Copy link

ollie05w commented May 26, 2017

Guys I found a password for it
What I did for both debugging and without debugging for when it says think before you type
The password I guessed is
Passwd= localhost lower case
This was lucky I tried so many others it's only this what I found to work

@ollie05w

This comment has been minimized.

Copy link

ollie05w commented May 26, 2017

Localhost is the password

@aleksclark

This comment has been minimized.

Copy link

aleksclark commented Jun 14, 2017

for what it's worth, I discovered the following: the root password you set when enabling debugging tools will work over SSH but will NOT work from the local shell. if you ssh in as root, you can then change all the passwords to be what you want.

@johanwitters

This comment has been minimized.

Copy link

johanwitters commented Jun 27, 2017

Thanks @aleksclark That's the solution for me

@cierracarmon18

This comment has been minimized.

Copy link

cierracarmon18 commented Aug 13, 2017

The ssh root@localhost keeps refusing the connection I'm not really computer savvy but installing the software did take so long of a time I don't wish to resit through it I just need to reset the password and this is frustrating

@jschnarr

This comment has been minimized.

Copy link

jschnarr commented Aug 16, 2017

It's actually simpler than @aleksclark and I previously said, and SSH doesn't work reliably.

Press ctl+alt+forward (by forward I mean the F2 equivalent, not the right arrow). It will pop up the proper developer console which allows you to logon as root with the password you set during setup. It also has instructions for setting the chronos password properly using chromeos-setdevpasswd.

@patsprice

This comment has been minimized.

Copy link

patsprice commented Aug 17, 2017

Thank you @jschnarr, your solution worked perfectly.

@IgorGanapolsky

This comment has been minimized.

Copy link

IgorGanapolsky commented Sep 11, 2017

@johanwitters

Localhost is the password

No it is not

@mosesdel

This comment has been minimized.

Copy link

mosesdel commented Oct 26, 2017

what is the login and if possible how do you reset it

@patsprice

This comment has been minimized.

Copy link

patsprice commented Oct 26, 2017

I cannot remember exaclty but it prompted me sometime during the install, if I remember correctly. Now when I boot up, if I go CTRL-ALT-T, I get to the crosh prompt, then I type in shell and hit Enter and then I type in sudo enter-chroot and it prompts me for the password I set during install. At that point I am logged in as the username@localhost that I created during install.

To your question, where do you type in chromeos-setdevpaswd? If you go CTRL-ALT-T and type in shell and hit Enter, you will be at a chronos@localhost / $ prompt. Then you sudo su to root and type your command, like so:
chronos@localhost / $ sudo su
Password:
localhost / # chromeos-setdevpasswd
Password:
Verifying - Password:
localhost / #

@KevinVandy

This comment has been minimized.

Copy link

KevinVandy commented Dec 1, 2017

Took me a while to find all the relevant information on this page, but I was able to figure it out. I had the same problem OP had. I made a root password while putting it into developer mode, but that password did not work in the crosh prompt (Ctrl + Alt + t). Here is exactly what worked for my asus chromebook flip c302 chromeos ver 63.

  1. Press Ctrl-Alt-forward
  2. Login as the user "root" and the password that you made while putting it into developer mode.
  3. You should be in as localhost now. Then from here you can set a new password that works in your crosh shell. So, in the shell that we just logged into, type the command
    chromeos-setdevpasswd
    then you can set a password, which you will probably want to be the same password that you just used if you want to keep it simple.
  4. After you have set the password from that prompt you can get sudo privileges with that password.
@tomford007

This comment has been minimized.

Copy link

tomford007 commented Mar 16, 2018

KevinVandy, THANK YOUUUUUUUUU!!!!!

@jonmorales89

This comment has been minimized.

Copy link

jonmorales89 commented Mar 22, 2018

@KevinVandy , thank you! Worked for me on an Acer C910.

@laurentschneider

This comment has been minimized.

Copy link

laurentschneider commented Jun 9, 2018

if you set a root password for debugging, use it with

ssh root@localhost

from shell (CTRL-ALT-T + shell)

@primeroseis

This comment has been minimized.

Copy link

primeroseis commented Aug 11, 2018

I had the same issue installing crouton on a samsung chromebook, and solved it skipping to check the debugger features as user adhoc92 pointed out..... I am still waiting for the install to conclude .....but would like to know which might be a good forum about how to use the xfce desktop all the links I follow point to unity ... Thanks for any advice

@patsprice

This comment has been minimized.

Copy link

patsprice commented Aug 12, 2018

@amesy

This comment has been minimized.

Copy link

amesy commented Sep 15, 2018

if you set a root password for debugging, use it with

ssh root@localhost

from shell (CTRL-ALT-T + shell)

Thank you, your method successfully solved my problem!

@citydesi

This comment has been minimized.

Copy link

citydesi commented Feb 4, 2019

THANKS TO KEVIN

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment