Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

17.12.0-ce-mac47 does not finish launching #2452

Closed
hakamadare opened this issue Jan 17, 2018 · 6 comments

Comments

@hakamadare
Copy link

commented Jan 17, 2018

Diagnostic ID: 44BAF7CF-03F6-4621-AA11-FAD1DA2CA04C

Expected behavior

  1. Launch Docker.app.
  2. Docker.app launches, menuling appears.
  3. Menuling application stops, docker daemon is running.

Actual behavior

  1. Launch Docker.app.
  2. Docker.app launches, menuling appears.
  3. Error dialog: "Fatal Error com.docker.supervisor failed to start
    Exit code 1"

Information

  • Full output of the diagnostics from "Diagnose & Feedback" in the menu
Docker for Mac: version: 17.12.0-ce-mac47 (72b93a017350990850ddc37cd341bd16fce3e911)
macOS: version 10.13.2 (build: 17C88)
logs: /tmp/44BAF7CF-03F6-4621-AA11-FAD1DA2CA04C/20180117-094834.tar.gz
failure: com.docker.vpnkit is not running
[OK]     db.git
[OK]     vmnetd
[OK]     dns
[ERROR]  driver.amd64-linux
         com.docker.driver.amd64-linux is not running
[OK]     virtualization VT-X
[OK]     app
[ERROR]  moby
         /Users/rk/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/console-ring does not exist
[OK]     system
[OK]     moby-syslog
[OK]     kubernetes
[OK]     env
[OK]     virtualization kern.hv_support
[ERROR]  slirp
         Unexpected error ((Failure
  "Error connecting socket to 9p endpoint unix:/Users/rk/Library/Containers/com.docker.docker/Data/s51: Unix.Unix_error(Unix.ECONNREFUSED, \"connect\", \"\")")) connecting to /Users/rk/Library/Containers/com.docker.docker/Data/s51
         com.docker.vpnkit is not running
         slirp check failed with: Unix.Unix_error(Unix.ECONNREFUSED, "connect", "")
[ERROR]  osxfs
         com.docker.osxfs is not running
[OK]     moby-console
[OK]     logs
[ERROR]  docker-cli
         Connection refused (ECONNREFUSED) connecting to /var/run/docker.sock: check if service is running
         Connection refused (ECONNREFUSED) connecting to /Users/rk/Library/Containers/com.docker.docker/Data/s60: check if service is running
         docker ps failed
[OK]     menubar
[OK]     disk

Steps to reproduce the behavior

  1. Launch Docker.app

Troubleshooting steps I have tried

  1. Reset Docker to factory defaults, relaunch
  2. brew cask zap docker && brew cask install docker
@hakamadare

This comment has been minimized.

Copy link
Author

commented Jan 17, 2018

#2453 and #2447 look like duplicates of this issue, perhaps?

@hakamadare

This comment has been minimized.

Copy link
Author

commented Jan 17, 2018

rolling back to 17.09.0-ce-mac35 (19611) resulted in a Docker.app that would launch successfully and a running docker daemon.

@akimd

This comment has been minimized.

Copy link
Contributor

commented Jan 17, 2018

Hi!

Could you please try this modified version of Docker 17.12? Ignore upgrades it might propose. Hopefully it should fix your issue. If it does, we will soon release an official stable image which includes the fix. Once you tested it, be sure to reinstall a "real" stable release.

https://download-stage.docker.com/mac/pr/21923/Docker.dmg

@akimd

This comment has been minimized.

Copy link
Contributor

commented Jan 18, 2018

Could you please check if the following image fixes your problems? You might need to reset to factory defaults...

https://download-stage.docker.com/mac/pr/21949/Docker.dmg

This is a test build. Ignore any update it might propose, and after testing, reinstall an Edge or Stable version to get proper updates again. Thanks!

@gtardif

This comment has been minimized.

Copy link
Contributor

commented Jan 19, 2018

We just released 17.12.0-ce-mac49 on the Stable channel that should fix this. (and 18.01 on the Edge channel also fixes this)

@gtardif gtardif closed this Jan 19, 2018

@hakamadare

This comment has been minimized.

Copy link
Author

commented Jan 19, 2018

confirmed, 17.12.0-ce-mac49 works for me. thank you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.