Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 33 lines (28 sloc) 1.335 kb
b67ef21 Dan McClain Initial commit, takes array conversion method
danmcclain authored
1 # -*- encoding: utf-8 -*-
2 require File.expand_path('../lib/postgres_ext/version', __FILE__)
3
4 Gem::Specification.new do |gem|
013cef8 Dan McClain Documentation
danmcclain authored
5 gem.authors = ["Dan McClain"]
6 gem.email = ["git@danmcclain.net"]
7 gem.description = %q{Adds missing native PostgreSQL data types to ActiveRecord}
8 gem.summary = %q{Extends ActiveRecord to handle native PostgreSQL data types}
b67ef21 Dan McClain Initial commit, takes array conversion method
danmcclain authored
9 gem.homepage = ""
10
11 gem.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
12 gem.files = `git ls-files`.split("\n")
13 gem.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
14 gem.name = "postgres_ext"
15 gem.require_paths = ["lib"]
16 gem.version = PostgresExt::VERSION
17
f5636dd Dan McClain Setting up test environment
danmcclain authored
18 gem.add_dependency 'activerecord', '~> 3.2.0'
a3c3540 Dan McClain Bumps pg_array_parser version and adds jruby to travis-ci
danmcclain authored
19 gem.add_dependency 'pg_array_parser', '~> 0.0.2'
f5636dd Dan McClain Setting up test environment
danmcclain authored
20
21 gem.add_development_dependency 'rails', '~> 3.2.0'
22 gem.add_development_dependency 'rspec-rails', '~> 2.9.0'
23 gem.add_development_dependency 'bourne', '~> 1.1.2'
c6a5620 Dan McClain Fixes gemspec dev dependencies
danmcclain authored
24 if RUBY_PLATFORM =~ /java/
25 gem.add_development_dependency 'pg', '~> 0.13.2'
26 else
27 gem.add_development_dependency 'activerecord-jdbcpostgresql-adapter'
28 end
ef344d6 Dan McClain Fixing gemspec for Travis
danmcclain authored
29 gem.add_development_dependency 'debugger', '~> 1.1.2' if RUBY_VERSION == '1.9.3'
0145940 Dan McClain Test inet data type migrations
danmcclain authored
30 gem.add_development_dependency 'fivemat'
c92918a Dan McClain Fixes array regex on 1.8.7, sets up rvm-tester
danmcclain authored
31 gem.add_development_dependency 'rvm-tester'
b67ef21 Dan McClain Initial commit, takes array conversion method
danmcclain authored
32 end
Something went wrong with that request. Please try again.