New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not working with Docpad 6.80.3 #6

Closed
johnwu opened this Issue Jul 17, 2018 · 8 comments

Comments

Projects
None yet
3 participants
@johnwu

johnwu commented Jul 17, 2018

Was working with docpad 6.79.4, but after updating to 6.80.3 seeing the following error:

[33mwarning:[39m Failed to load the plugin: docpad-plugin-consolidate at /Volumes/Data/Users/username/Documents/projects/website/node_modules/docpad-plugin-consolidate
The error follows:

TypeError: Class constructor BasePlugin cannot be invoked without 'new'
    at new ConsolidatePlugin (/Volumes/Data/Users/username/Documents/projects/website/node_modules/docpad-plugin-consolidate/out/lib/consolidate.plugin.js:23:49)
    at PluginLoader.create (/Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/plugin-loader.js:260:26)
    at /Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/docpad.js:3600:29
    at PluginLoader.load (/Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/plugin-loader.js:240:7)
    at /Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/docpad.js:3595:27
    at PluginLoader.unsupported (/Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/plugin-loader.js:146:7)
    at /Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/docpad.js:3573:25
    at success (/Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/plugin-loader.js:71:16)
    at safefs.readFile (/Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/esnext/lib/plugin-loader.js:110:18)
    at /Volumes/Data/Users/username/.nvm/versions/node/v8.11.3/lib/node_modules/docpad/node_modules/graceful-fs/graceful-fs.js:78:16
    at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:511:3)
@RobLoach

This comment has been minimized.

Member

RobLoach commented Jul 17, 2018

Thanks! Likely could do with an update.

@johnwu

This comment has been minimized.

johnwu commented Aug 12, 2018

How about transferring it Docpad to maintain?
https://docpad.org/docs/plugin-write#maintenance

@RobLoach

This comment has been minimized.

Member

RobLoach commented Aug 12, 2018

@balupton

This comment has been minimized.

Member

balupton commented Aug 17, 2018

Package just needs https://github.com/bevry/boundation run on it.

For the meantime, you can get compatibility by running the following:

env EDITIONS_SYNTAX_BLACKLIST=esnext docpad run
@balupton

This comment has been minimized.

Member

balupton commented Aug 19, 2018

@RobLoach can you run:

  • npm owner add balupton docpad-plugin-consolidate
  • npm owner add bevryme docpad-plugin-consolidate
@RobLoach

This comment has been minimized.

Member

RobLoach commented Aug 19, 2018

Thanks 👍

@balupton

This comment has been minimized.

Member

balupton commented Aug 20, 2018

I've got it going locally, but too tired to push up today. Will do it over the next few days.

@balupton

This comment has been minimized.

Member

balupton commented Oct 1, 2018

v2.3.0 now out which resolves this issue

@balupton balupton closed this Oct 1, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment