New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incompatible with DocPad v6.80 and above #17

Open
cattermo opened this Issue Sep 24, 2018 · 7 comments

Comments

Projects
None yet
4 participants
@cattermo
Copy link

cattermo commented Sep 24, 2018

Plugin requires updating to CoffeeScript v2. This can be done automatically via running https://github.com/bevry/boundation on it.
If you would like the DocPad team to do it, then transfer the repo to the https://github.com/docpad organisation, and run the following:

npm owner add balupton docpad-plugin-assets
npm owner add bevryme docpad-plugin-assets

@rantecki

This comment has been minimized.

Copy link
Collaborator

rantecki commented Sep 24, 2018

I'm happy to transfer this, but I need permission to create repo's on the 'docpad' organisation to do so?

@rantecki

This comment has been minimized.

Copy link
Collaborator

rantecki commented Sep 24, 2018

FYI - I've updated the npm package owners

@balupton

This comment has been minimized.

Copy link
Member

balupton commented Sep 25, 2018

Just added @rantecki to the docpad extras team, once you accept you should be able to transfer

@rantecki

This comment has been minimized.

Copy link
Collaborator

rantecki commented Sep 26, 2018

Ok, this is done.

@balupton

This comment has been minimized.

Copy link
Member

balupton commented Sep 26, 2018

Great, I'll get to the upgrade with the rest of them.

@fmanaya

This comment has been minimized.

Copy link

fmanaya commented Oct 6, 2018

Sorry, I just saw this issue after fork and work upgrading this plugin. This is the repo https://github.com/fmanaya/docpad-plugin-thumbnails.
I make changes from plugin template (docpad-plugin-yourpluginname) and not using boundation.
Unfortunately I'am not able tu pass the tests. I think it fail first on constructor...
So, after this issue, I am not sure what is the way.
If you transfer and upgrade this plugin soon i can wait. If not, maybe you can give me some hint to fix it.
Thank you very match

@balupton

This comment has been minimized.

Copy link
Member

balupton commented Oct 6, 2018

I've got this plugin converted locally but got some spontaneous failing tests, more details here:

docpad/docpad-plugin-assets#5 (comment)

I'll have a fix out hopefully next week (requires some changes to docpad-plugintester). Got a few time critical tasks to knock off first though.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment