New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

New DocPad v6.80.0 release #1076

Closed
balupton opened this Issue Jul 12, 2018 · 0 comments

Comments

Projects
None yet
2 participants
@balupton
Copy link
Member

balupton commented Jul 12, 2018

So the first minor release in nearly two years (v6.79.0 was released on 2016 September 27).

Those years did not go unspent though, every single bevry package was updated, and this release includes all of it. See its changelog for full details.


Changelog: https://github.com/docpad/docpad/blob/master/HISTORY.md#v6800-2018-july-12

Documentation: http://v6.80.0.docpad.docpad.surge.sh/docs/

Install Globally: npm install -g docpad@6.80

Install Locally: npm install --save docpad@6.80

Running it with CoffeeScript v1 Plugins:

env EDITIONS_SYNTAX_BLACKLIST=esnext docpad run

Running it with all CoffeeScript v2 Plugins:

docpad run

To upgrade a plugin to CoffeeScript v2 and the latest conventions, have the plugin maintainer run boundation on their plugin repository.


Known issues:


Use this thread for any errors related specifically to the upgrade process. Otherwise, use our discussion forum.

v6.80 will probably be the last DocPad release. See #1072 for discussion.

Let me know what you think, or if I am just wasting my time with DocPad. Cheers!

Any help with the below error reports would be fantastic.

/cc @docpad/core-team @docpad/extras-team @docpad/meta-team

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment