Skip to content

Loading…

npm install docpad@6.53 not working #646

Closed
s2zaman opened this Issue · 9 comments

3 participants

@s2zaman

Some error portion of the npm install -g docpad@6.53
I think my previous issue #644 actually started from here, because the docpad was not installed and i was working on further npm commands.
Now I re-installed the 'node and npm', but the problem still exists.
What would be solution for this issue.

The npm-debug.log is here

2365 info install query-engine@1.5.2
2366 info C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\mime unbuild
2367 info C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\taskgroup unbuild
2368 info C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\bal-util unbuild
2369 info C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\extendr unbuild
2370 silly gunzTarPerm extractEntry lib/router/route.js
2371 silly gunzTarPerm modified mode [ 'lib/router/route.js', 438, 420 ]
2372 info postinstall query-engine@1.5.2
2373 verbose tar unpack C:\Users\VCR1\AppData\Roaming\npm-cache\taskgroup\3.1.2\package.tgz
2374 silly lockFile 8878164e-es-watchr-node-modules-taskgroup tar://C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\taskgroup
2375 verbose lock tar://C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\taskgroup C:\Users\VCR1\AppData\Roaming\npm-cache\8878164e-es-watchr-node-modules-taskgroup.lock
2376 silly lockFile ab766059-ache-taskgroup-3-1-2-package-tgz tar://C:\Users\VCR1\AppData\Roaming\npm-cache\taskgroup\3.1.2\package.tgz
2377 verbose lock tar://C:\Users\VCR1\AppData\Roaming\npm-cache\taskgroup\3.1.2\package.tgz C:\Users\VCR1\AppData\Roaming\npm-cache\ab766059-ache-taskgroup-3-1-2-package-tgz.lock
2378 verbose tar unpack C:\Users\VCR1\AppData\Roaming\npm-cache\bal-util\2.0.5\package.tgz
2379 silly lockFile 16d12ceb-les-watchr-node-modules-bal-util tar://C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\bal-util
2380 verbose lock tar://C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\bal-util C:\Users\VCR1\AppData\Roaming\npm-cache\16d12ceb-les-watchr-node-modules-bal-util.lock
2381 silly lockFile f922d1d7-cache-bal-util-2-0-5-package-tgz tar://C:\Users\VCR1\AppData\Roaming\npm-cache\bal-util\2.0.5\package.tgz
2382 verbose lock tar://C:\Users\VCR1\AppData\Roaming\npm-cache\bal-util\2.0.5\package.tgz C:\Users\VCR1\AppData\Roaming\npm-cache\f922d1d7-cache-bal-util-2-0-5-package-tgz.lock
2383 verbose tar unpack C:\Users\VCR1\AppData\Roaming\npm-cache\extendr\2.0.1\package.tgz
2384 silly lockFile a50af76e-ules-watchr-node-modules-extendr tar://C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\extendr
2385 verbose lock tar://C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\watchr\node_modules\extendr C:\Users\VCR1\AppData\Roaming\npm-cache\a50af76e-ules-watchr-node-modules-extendr.lock
2386 silly lockFile ce0bc3dc--cache-extendr-2-0-1-package-tgz tar://C:\Users\VCR1\AppData\Roaming\npm-cache\extendr\2.0.1\package.tgz
2387 verbose lock tar://C:\Users\VCR1\AppData\Roaming\npm-cache\extendr\2.0.1\package.tgz C:\Users\VCR1\AppData\Roaming\npm-cache\ce0bc3dc--cache-extendr-2-0-1-package-tgz.lock
2388 info preinstall bal-util@2.3.0
2389 silly gunzTarPerm modes [ '755', '644' ]
2390 silly gunzTarPerm modes [ '755', '644' ]
2391 verbose readDependencies using package.json deps
2392 verbose readDependencies using package.json deps
2393 verbose cache add [ 'ambi@~2.0.0', null ]
2394 verbose cache add name=undefined spec="ambi@~2.0.0" args=["ambi@~2.0.0",null]
2395 verbose parsed url { protocol: null,
2395 verbose parsed url   slashes: null,
2395 verbose parsed url   auth: null,
2395 verbose parsed url   host: null,
2395 verbose parsed url   port: null,
2395 verbose parsed url   hostname: null,
2395 verbose parsed url   hash: null,
2395 verbose parsed url   search: null,
2395 verbose parsed url   query: null,
2395 verbose parsed url   pathname: 'ambi@~2.0.0',
2395 verbose parsed url   path: 'ambi@~2.0.0',
2395 verbose parsed url   href: 'ambi@~2.0.0' }
2396 verbose cache add name="ambi" spec="~2.0.0" args=["ambi","~2.0.0"]
2397 verbose parsed url { protocol: null,
2397 verbose parsed url   slashes: null,
2397 verbose parsed url   auth: null,
2397 verbose parsed url   host: null,
2397 verbose parsed url   port: null,
2397 verbose parsed url   hostname: null,
2397 verbose parsed url   hash: null,
2397 verbose parsed url   search: null,
2397 verbose parsed url   query: null,
2397 verbose parsed url   pathname: '~2.0.0',
2397 verbose parsed url   path: '~2.0.0',
2397 verbose parsed url   href: '~2.0.0' }
2398 verbose addNamed [ 'ambi', '~2.0.0' ]
2399 verbose addNamed [ null, '>=2.0.0-0 <2.1.0-0' ]
2400 silly lockFile 071e82fa-ambi-2-0-0 ambi@~2.0.0
2401 verbose lock ambi@~2.0.0 C:\Users\VCR1\AppData\Roaming\npm-cache\071e82fa-ambi-2-0-0.lock
2402 verbose cache add [ 'extendr@~2.0.1', null ]
2403 verbose cache add name=undefined spec="extendr@~2.0.1" args=["extendr@~2.0.1",null]
2404 verbose parsed url { protocol: null,
2404 verbose parsed url   slashes: null,
2404 verbose parsed url   auth: null,
2404 verbose parsed url   host: null,
2404 verbose parsed url   port: null,
2404 verbose parsed url   hostname: null,
2404 verbose parsed url   hash: null,
2404 verbose parsed url   search: null,
2404 verbose parsed url   query: null,
2404 verbose parsed url   pathname: 'extendr@~2.0.1',
2404 verbose parsed url   path: 'extendr@~2.0.1',
2404 verbose parsed url   href: 'extendr@~2.0.1' }
2405 verbose cache add name="extendr" spec="~2.0.1" args=["extendr","~2.0.1"]
2406 verbose parsed url { protocol: null,
2406 verbose parsed url   slashes: null,
2406 verbose parsed url   auth: null,
2406 verbose parsed url   host: null,
2406 verbose parsed url   port: null,
2406 verbose parsed url   hostname: null,
2406 verbose parsed url   hash: null,
2406 verbose parsed url   search: null,
2406 verbose parsed url   query: null,
2406 verbose parsed url   pathname: '~2.0.1',
2406 verbose parsed url   path: '~2.0.1',
2406 verbose parsed url   href: '~2.0.1' }
2407 verbose addNamed [ 'extendr', '~2.0.1' ]
2408 verbose addNamed [ null, '>=2.0.1-0 <2.1.0-0' ]
2409 silly lockFile 086f8153-extendr-2-0-1 extendr@~2.0.1
2410 verbose lock extendr@~2.0.1 C:\Users\VCR1\AppData\Roaming\npm-cache\086f8153-extendr-2-0-1.lock
2411 verbose cache add [ 'taskgroup@~3.1.1', null ]
2412 verbose cache add name=undefined spec="taskgroup@~3.1.1" args=["taskgroup@~3.1.1",null]
2413 verbose parsed url { protocol: null,
2413 verbose parsed url   slashes: null,
2413 verbose parsed url   auth: null,
2413 verbose parsed url   host: null,
2413 verbose parsed url   port: null,
2413 verbose parsed url   hostname: null,
2413 verbose parsed url   hash: null,
2413 verbose parsed url   search: null,
2413 verbose parsed url   query: null,
2413 verbose parsed url   pathname: 'taskgroup@~3.1.1',
2413 verbose parsed url   path: 'taskgroup@~3.1.1',
2413 verbose parsed url   href: 'taskgroup@~3.1.1' }
2414 verbose cache add name="taskgroup" spec="~3.1.1" args=["taskgroup","~3.1.1"]
2415 verbose parsed url { protocol: null,
2415 verbose parsed url   slashes: null,
2415 verbose parsed url   auth: null,
2415 verbose parsed url   host: null,
2415 verbose parsed url   port: null,
2415 verbose parsed url   hostname: null,
2415 verbose parsed url   hash: null,
2415 verbose parsed url   search: null,
2415 verbose parsed url   query: null,
2415 verbose parsed url   pathname: '~3.1.1',
2415 verbose parsed url   path: '~3.1.1',
2415 verbose parsed url   href: '~3.1.1' }
2416 verbose addNamed [ 'taskgroup', '~3.1.1' ]
2417 verbose addNamed [ null, '>=3.1.1-0 <3.2.0-0' ]
2418 silly lockFile 9c8db6ff-taskgroup-3-1-1 taskgroup@~3.1.1
2419 verbose lock taskgroup@~3.1.1 C:\Users\VCR1\AppData\Roaming\npm-cache\9c8db6ff-taskgroup-3-1-1.lock
2420 error Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\event-emitter-grouped\node_modules\taskgroup\LICENSE.md'
2421 error If you need help, you may report this log at:
2421 error     <http://github.com/isaacs/npm/issues>
2421 error or email it to:
2421 error     <npm-@googlegroups.com>
2422 error System Windows_NT 6.2.9200
2423 error command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "docpad@6.53"
2424 error cwd C:\Windows\system32
2425 error node -v v0.10.18
2426 error npm -v 1.3.8
2427 error path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\event-emitter-grouped\node_modules\taskgroup\LICENSE.md
2428 error fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\event-emitter-grouped\node_modules\taskgroup\LICENSE.md
2429 error fstream_type File
2430 error fstream_class FileWriter
2431 error code ENOENT
2432 error errno 34
2433 error fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fstream\lib\writer.js:284:26
2433 error fstream_stack Object.oncomplete (fs.js:107:15)
2434 verbose exit [ 34, true ]

The Error Generated is here

npm http 304 https://registry.npmjs.org/caterpillar-filter
npm http 304 https://registry.npmjs.org/taskgroup

> ambi@2.1.3 preinstall C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\no
de_modules\ambi
> node -e "if(require('fs').existsSync('./.git')){ require('child_process').spaw
n('npm', ['install','--force',require('./package.json').name], {env:process.env,
cwd:process.cwd(),stdio:'inherit'}); }"

npm http GET https://registry.npmjs.org/progress/0.1.0
npm http GET https://registry.npmjs.org/ansistyles
npm http GET https://registry.npmjs.org/ansicolors
npm http GET https://registry.npmjs.org/joe-reporter-console
npm http GET https://registry.npmjs.org/joe

[eval]:1

> typechecker@2.0.3 preinstall C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
cpad\node_modules\typechecker
> node -e "if(require('fs').existsSync('./.git')){ require('child_process').spaw
n('npm', ['install','--force',require('./package.json').name], {env:process.env,
cwd:process.cwd(),stdio:'inherit'}); }"

"if(require('fs').existsSync('./.git')){
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
npm http GET https://registry.npmjs.org/readable-stream
SyntaxError: Unexpected token ILLEGAL
    at Object.<anonymous> ([eval]-wrapper:6:22)
    at Module._compile (module.js:456:26)
    at evalScript (node.js:532:25)
    at startup (node.js:80:7)
    at node.js:901:3

[eval]:1
"if(require('fs').existsSync('./.git')){
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
SyntaxError: Unexpected token ILLEGAL
    at Object.<anonymous> ([eval]-wrapper:6:22)
    at Module._compile (module.js:456:26)
    at evalScript (node.js:532:25)
    at startup (node.js:80:7)
    at node.js:901:3

> taskgroup@3.2.2 preinstall C:\Users\VCR1\AppData\Roaming\npm\node_modules\docp
ad\node_modules\taskgroup
> node -e "if(require('fs').existsSync('./.git')){ require('child_process').spaw
n('npm', ['install','--force',require('./package.json').name], {env:process.env,
cwd:process.cwd(),stdio:'inherit'}); }"

npm http GET https://registry.npmjs.org/read
npm http
GET https://registry.npmjs.org/requirefresh
[eval]:1
"if(require('fs').existsSync('./.git')){
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
npm http GET https://registry.npmjs.org/coffee-script
SyntaxError: Unexpected token ILLEGAL
    at Object.<anonymous> ([eval]-wrapper:6:22)
    at Module._compile (module.js:456:26)
    at evalScript (node.js:532:25)
    at startup (node.js:80:7)
    at node.js:901:3
npm http GET https://registry.npmjs.org/js2coffee
npm ERR! Error: ENOENT, chmod 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
cpad\node_modules\backbone\backbone-min.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules
\backbone\backbone-min.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node
_modules\backbone\backbone-min.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call chmod
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fst
ream\lib\writer.js:305:19
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir 'C:\Users\VCR1\AppData\Roami
ng\npm\node_modules\docpad\node_modules\express\lib'
npm ERR! error rolling back  docpad@6.53.0 { [Error: ENOTEMPTY, rmdir 'C:\Users\
VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\express\lib']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: 'C:\\Users\\VCR1\\AppData\\Roaming\\npm\\nod
e_modules\\docpad\\node_modules\\express\\lib' }
npm ERR! weird error 8
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
cpad\node_modules\jschardet\src\gb2312prober.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules
\jschardet\src\gb2312prober.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node
_modules\jschardet\src\gb2312prober.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fst
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
cpad\node_modules\express\lib\application.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules
\express\lib\application.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node
_modules\express\lib\application.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fst
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
cpad\node_modules\watchr\node_modules\taskgroup\example.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules
\watchr\node_modules\taskgroup\example.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node
_modules\watchr\node_modules\taskgroup\example.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fst
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, open 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\doc
pad\node_modules\watchr\node_modules\bal-util\out\lib\compare.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules
\watchr\node_modules\bal-util\out\lib\compare.js
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
cpad\node_modules\yamljs\bin\yaml2json'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules
\yamljs\bin\yaml2json
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node
_modules\yamljs\bin\yaml2json
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fst
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
cpad\node_modules\lodash\dist\lodash.compat.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nod
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules
\lodash\dist\lodash.compat.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node
_modules\lodash\dist\lodash.compat.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fst
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/joe-reporter-console
npm http 304 https://registry.npmjs.org/progress/0.1.0
npm http 304 https://registry.npmjs.org/joe
npm http 304 https://registry.npmjs.org/readable-stream
npm http 304 https://registry.npmjs.org/ansistyles
npm http 304 https://registry.npmjs.org/coffee-script
npm http 304 https://registry.npmjs.org/requirefresh
npm http 304 https://registry.npmjs.org/ansicolors
npm http GET https://registry.npmjs.org/cli-color
npm http 304 https://registry.npmjs.org/js2coffee
npm http GET https://registry.npmjs.org/file
npm http GET https://registry.npmjs.org/underscore
npm http 304 https://registry.npmjs.org/cli-color
npm http GET https://registry.npmjs.org/memoizee
npm http 304 https://registry.npmjs.org/file
npm http GET https://registry.npmjs.org/es5-ext
npm http 304 https://registry.npmjs.org/underscore
npm http 304 https://registry.npmjs.org/read
npm http GET https://registry.npmjs.org/mute-stream
npm http 304 https://registry.npmjs.org/memoizee
npm http 304 https://registry.npmjs.org/es5-ext
npm http GET https://registry.npmjs.org/next-tick
npm http GET https://registry.npmjs.org/event-emitter
npm http 304 https://registry.npmjs.org/mute-stream
npm http 304 https://registry.npmjs.org/next-tick
npm http 304 https://registry.npmjs.org/event-emitter
...
...
> ambi@2.1.3 preinstall C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\n
de_modules\ambi
> node -e "if(require('fs').existsSync('./.git')){ require('child_process').spa
n('npm', ['install','--force',require('./package.json').name], {env:process.env
cwd:process.cwd(),stdio:'inherit'}); }"

npm http GET https://registry.npmjs.org/progress/0.1.0
npm http GET https://registry.npmjs.org/ansistyles
npm http GET https://registry.npmjs.org/ansicolors
npm http GET https://registry.npmjs.org/joe-reporter-console
npm http GET https://registry.npmjs.org/joe

[eval]:1

> typechecker@2.0.3 preinstall C:\Users\VCR1\AppData\Roaming\npm\node_modules\d
cpad\node_modules\typechecker
> node -e "if(require('fs').existsSync('./.git')){ require('child_process').spa
n('npm', ['install','--force',require('./package.json').name], {env:process.env
cwd:process.cwd(),stdio:'inherit'}); }"

"if(require('fs').existsSync('./.git')){
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
npm http GET https://registry.npmjs.org/readable-stream
SyntaxError: Unexpected token ILLEGAL
    at Object.<anonymous> ([eval]-wrapper:6:22)
    at Module._compile (module.js:456:26)
    at evalScript (node.js:532:25)
    at startup (node.js:80:7)
    at node.js:901:3

[eval]:1
"if(require('fs').existsSync('./.git')){
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
SyntaxError: Unexpected token ILLEGAL
    at Object.<anonymous> ([eval]-wrapper:6:22)
    at Module._compile (module.js:456:26)
    at evalScript (node.js:532:25)
    at startup (node.js:80:7)
    at node.js:901:3

> taskgroup@3.2.2 preinstall C:\Users\VCR1\AppData\Roaming\npm\node_modules\doc
ad\node_modules\taskgroup
> node -e "if(require('fs').existsSync('./.git')){ require('child_process').spa
n('npm', ['install','--force',require('./package.json').name], {env:process.env
cwd:process.cwd(),stdio:'inherit'}); }"

npm http GET https://registry.npmjs.org/read
npm http
GET https://registry.npmjs.org/requirefresh
[eval]:1
"if(require('fs').existsSync('./.git')){
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
npm http GET https://registry.npmjs.org/coffee-script
SyntaxError: Unexpected token ILLEGAL
    at Object.<anonymous> ([eval]-wrapper:6:22)
    at Module._compile (module.js:456:26)
    at evalScript (node.js:532:25)
    at startup (node.js:80:7)
    at node.js:901:3
npm http GET https://registry.npmjs.org/js2coffee
npm ERR! Error: ENOENT, chmod 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\d
cpad\node_modules\backbone\backbone-min.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_module
\backbone\backbone-min.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\nod
_modules\backbone\backbone-min.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call chmod
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fs
ream\lib\writer.js:305:19
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir 'C:\Users\VCR1\AppData\Roam
ng\npm\node_modules\docpad\node_modules\express\lib'
npm ERR! error rolling back  docpad@6.53.0 { [Error: ENOTEMPTY, rmdir 'C:\Users
VCR1\AppData\Roaming\npm\node_modules\docpad\node_modules\express\lib']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: 'C:\\Users\\VCR1\\AppData\\Roaming\\npm\\no
e_modules\\docpad\\node_modules\\express\\lib' }
npm ERR! weird error 8
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\d
cpad\node_modules\jschardet\src\gb2312prober.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_module
\jschardet\src\gb2312prober.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\nod
_modules\jschardet\src\gb2312prober.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fs
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\d
cpad\node_modules\express\lib\application.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_module
\express\lib\application.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\nod
_modules\express\lib\application.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fs
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\d
cpad\node_modules\watchr\node_modules\taskgroup\example.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_module
\watchr\node_modules\taskgroup\example.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\nod
_modules\watchr\node_modules\taskgroup\example.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fs
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, open 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\do
pad\node_modules\watchr\node_modules\bal-util\out\lib\compare.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_module
\watchr\node_modules\bal-util\out\lib\compare.js
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\d
cpad\node_modules\yamljs\bin\yaml2json'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_module
\yamljs\bin\yaml2json
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\nod
_modules\yamljs\bin\yaml2json
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fs
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\VCR1\AppData\Roaming\npm\node_modules\d
cpad\node_modules\lodash\dist\lodash.compat.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-global" "docpad@6.53"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.10.18
npm ERR! npm -v 1.3.8
npm ERR! path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\node_module
\lodash\dist\lodash.compat.js
npm ERR! fstream_path C:\Users\VCR1\AppData\Roaming\npm\node_modules\docpad\nod
_modules\lodash\dist\lodash.compat.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fs
ream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

[1]:

@balupton
DocPad member

Hrmm, I know what it is related to, but I don't know why you're experiencing problems. Can you provide your node, npm, and operating system versions. Also, can you add my on skype (username balupton) or google hangouts (balupton@gmail.com) and I'll debug with you.

@balupton
DocPad member

Actually, I can reproduce on my windows machine.

@s2zaman

I added you to google hangouts.
My PC info--

node --version: v0.10.18
npm --version: 1.3.8
OS: Windows 8 Pro 32-bit , x64-based processor, Intel Core i5 @ 3.33GHz

@balupton
DocPad member

Thanks. Figured out the issue. Fixing now.

@balupton
DocPad member

Just pushed some changes to some dependencies up, try this:

npm install -g --force docpad
@balupton
DocPad member

Just tested this on my machine, seems fixed now, a normal npm install -g docpad should do the trick

@balupton balupton closed this
@s2zaman

Yes!.................it worked.
You are greatly helping the git-fellows and the community!
Thanks a lot !!

@v3rde

Hi! I get kinda issue when try to install 6.65 version.
Installed 6.63 and It's ok.

@balupton
DocPad member

@v3rde can you send over any debug or log information that is outputted, that would be great. Having it in a gist then linking it would be fantastic too.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.