Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

An error occured: Cannot find module 'uglify-js' #137

Closed
wants to merge 1 commit into from

2 participants

@pismute

Docpad requires 'uglify-js' module. I got a message "An error occured: Cannot find module 'uglify-js'".

@pismute pismute Add uglify-js for dependencies
Docpad requires 'uglify-js'
0d9f5bb
@balupton
Owner

Very strange, I'd say the fix for this would actually be finding out whatever requires it and kill it - as we should keep the core to as minimal dependencies as possible (more dependencies, more risk of failure on different environments).

The culprit is perhaps the buildr plugin - which for now can be deleted.

Would you be able to look into this further, by tracking down the violator? If so, that'll be awesome!

@pismute

Thank you.

Ok, I will check it.

@pismute

It's Very strange. I updated all of modules. then I got same error message from socket.io-client module in autoupdate Plugin.

but I clone again. there are no error.:)

Thank you.

@pismute pismute closed this
@balupton
Owner

Figured out what this was. config.enabledPlugins if set by your website, would not be merged in with docpad's enabled plugins, instead it would overwrite it, thus enabling the disabled-by-default plugins.

This will be fixed in the upcoming version of docpad.

@balupton balupton reopened this
@balupton
Owner

Fixed in the just released v3.3.0 :-)

@balupton balupton closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Feb 18, 2012
  1. @pismute

    Add uglify-js for dependencies

    pismute authored
    Docpad requires 'uglify-js'
This page is out of date. Refresh to see the latest.
Showing with 3 additions and 2 deletions.
  1. +3 −2 package.json
View
5 package.json
@@ -60,7 +60,8 @@
"js2coffee": "0.1.x",
"underscore": "1.3.x",
"npm": ">=1.0.x",
- "semver": "1.0.x"
+ "semver": "1.0.x",
+ "uglify-js": "1.2.x"
},
"devDependencies": {
"request": "2.9.x",
@@ -79,4 +80,4 @@
"test": "node ./node_modules/mocha/bin/mocha --reporter spec --ui bdd --ignore-leaks --growl"
},
"main": "./lib/docpad.coffee"
-}
+}
Something went wrong with that request. Please try again.