• Sep 26, 2016

    v6.79.0

    v6.79.0 2016 September 27
    - Bumped coffee-script dependency version
    - Fixed possible `docpad not defined` issue on `loadLocale`
  • Jun 15, 2016

    v6.78.5

    v6.78.5 2016 June 15
    - Recompiled with latest dev dependencies
  • Sep 16, 2015

    v6.78.4

    v6.78.4 September 16, 2015
    - Fixed `path option is deprecated` error when cloning a skeleton
    	- Thanks to [Gabriel Ignisca](https://github.com/16nsk) for [issue #1016](#1016)
    - Changed donation message, maybe this one will be more successful
    - The next x.X.x release of DocPad will drop support for Node v0.10, Node v4.0.0 is out with many improvements. [Upgrade.](https://learn.bevry.me/node/install)
    - Updated dev dependencies
    - Updated base files
  • Aug 21, 2015

    v6.78.3

    v6.78.3 August 21, 2015
    - Consolidated server address code
    - DocPad will now output both the original server address and the simplified server address if they differ, background:
    	- 2b9f567#commitcomment-12824451
    	- #911
  • Aug 21, 2015

    v6.78.2

    v6.78.2 August 21, 2015
    - Profilers must now be specified by `DOCPAD_PROFILER` variable
    - Prevent waiting handles from being outputted in silent mode (prevents a common render test failure)
    - Use [hostenv](https://github.com/bevry/hostenv) for `PORT` and `HOSTNAME` variables
    - Listen to `0.0.0.0` hostname by default (will be outputted as `localhost`)
    - Updated dependencies
    - Updated base files
  • Mar 20, 2015

    v6.78.1

    v6.78.1 March 20, 2015
    - Fixed `queryEngine` is undefined error (regression since v6.78.1)
    	- Thanks to [wlbrough](https://github.com/wlbrough) for [issue #943](#943)
  • Mar 18, 2015

    v6.78.0

    v6.78.0 March 18, 2015
    - You can now `module.exports = function(docpad){ return {/* your docpad configuration */} }`
    
    cd # Write a message for tag:
  • Mar 18, 2015

    v6.77.1

    v6.77.1 March 18, 2015
    - Better error reporting when a custom collection is invalid
    	- Thanks to [Simon Smithies](https://github.com/simonsmithies) for [issue #875](#875)
  • Mar 18, 2015

    v6.77.0

    v6.77.0 March 18, 2015
    - Replaced `lodash` with `underscore`
    	- Backbone (our dependency) already includes `underscore`, so makes sense to reduce our footprint
    - Removed these deprecated exports:
    	- `require('docpad').DocPad`
    	- `require('docpad').Backbone`
    	- `require('docpad').queryEngine`
    	- `docpadInstance.View`
    - Added `progress` configuration option that you can use to disable progress bars
  • Mar 17, 2015

    v6.76.1

    v6.76.1 March 17, 2015
    - Fixed testers wanting chai (regression since v6.76.0)