Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Sf 2.1 and composer error when "doctrine/doctrine-fixtures-bundle" is required #55

Closed
AntonioAngelino opened this Issue · 6 comments

4 participants

@AntonioAngelino

Hello all,

I'd like to use DoctrineFixturesBundle with my Sf 2.1 project, but composer gave me error on doctrine doctrine-fixtures-bundle:

#: php composer.phar update doctrine/doctrine-fixtures-bundle --dev
Updating dependencies
Updating dev dependencies
  [InvalidArgumentException]
  Package is not installed: doctrine/doctrine-bundle-9999999-dev

I'm using latest ver of composer.phar and composer.json already includes "doctrine/doctrine-bundle": "dev-master" , so I don't understand what is wrong (everything else works). Is it a composer bug?

Regards,
Antonio.

@AntonioAngelino

I solved forking the repo and editing DoctrineFixturesBundle's composer.json:

remove "doctrine/doctrine-bundle": "1.0.*",

add "doctrine/doctrine-bundle": "dev-master",

Regards,
Antonio.

@ghost

That didn't work for me with Symfony 2.2-dev @stof

@stof
Collaborator

@AntonioAngelino this looks like a Composer bug

@drak I modified the composer.json to allow the 2.2 bridge

@ghost

Thanks @stof!!

@dbu
dbu commented

still a problem? i have seen this from time to time and the workaround is to run composer install twice, first time without --dev, then with the --dev

@jrobeson

this should be fixed for everybody now right?

@stof stof closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.